Crash [@ nsSVGSVGElement::GetLength] with stroke-width="100%"

RESOLVED FIXED

Status

()

--
critical
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: jruderman, Assigned: tor)

Tracking

({crash, regression, testcase})

Trunk
x86
Mac OS X
crash, regression, testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(3 attachments)

(Reporter)

Description

12 years ago
Created attachment 258143 [details]
testcase (crashes Firefox)

Loading the testcase in Firefox (nightly or debug) makes Firefox crash.

Regressed between 2007-03-09 and 2007-03-10 nightlies, so guessing this is a regression from bug 353172.
Flags: blocking1.9?
(Assignee)

Comment 1

12 years ago
Created attachment 258315 [details] [diff] [review]
pass in appropriate element as context
Attachment #258315 - Flags: review?(jwatt)
(Assignee)

Updated

12 years ago
Assignee: general → tor

Updated

12 years ago
Attachment #258315 - Flags: review?(jwatt) → review+
(Assignee)

Updated

12 years ago
Attachment #258315 - Flags: superreview?(roc)

Updated

12 years ago
Duplicate of this bug: 374271
(Assignee)

Comment 3

12 years ago
Comment on attachment 258315 [details] [diff] [review]
pass in appropriate element as context

An experiment in getting two peer reviews rather than r/sr for bugs that in the opinion of the author don't require an architecture/API check.
Attachment #258315 - Flags: superreview?(roc) → review?(longsonr)
Attachment #258315 - Flags: review?(longsonr) → review+
(Assignee)

Comment 5

12 years ago
Checked in.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 6

12 years ago
Was the reftest here ever committed?
Flags: in-testsuite?
Crash Signature: [@ nsSVGSVGElement::GetLength]
You need to log in before you can comment on or make changes to this bug.