Instantly pressing "Cancel" when prompted for master password on startup finally cause to disregard it.

RESOLVED DUPLICATE of bug 16489

Status

--
major
RESOLVED DUPLICATE of bug 16489
12 years ago
12 years ago

People

(Reporter: sky_u, Assigned: dveditz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: 1.5.0.10 (20070221)

Instantly pressing "Cancel" when prompted for master password on startup finally cause to disregard it. You can easily read the e-mails and maneuver through the mail client and you can even send new e-mails from your active accounts!

Reproducible: Always

Steps to Reproduce:
1. Start up the 'Thunderbird'
2. When prompted for master password press 'Cancel' 
3. (repeat the activity above 2 more times)
4. Press 'Cancel' when asked for your particular account password
5. Follow step 2,3,4 till you cancel requests for all of your accounts passwords
6. Now you are able to read/send emails
7. There should appear a prompt for master password in some time (approx. 1min.) but then press 'Cancel' again and 'you are at home'.
Actual Results:  
As in description. You are able to read messages and to send new e-mails.

Expected Results:  
Perhaps I would expect that program will exit. Definitely no messages headers should be visible nor content of any message till the correct master password is given.
(Assignee)

Comment 1

12 years ago
The password prompts are from your mail server -- you won't be able to get new mail without supplying it. If your mail server doesn't require a password to send mail then Thunderbird will not prompt you for one. Locally stored mail is protected by your operating system's user accounts if you use them.
Group: security
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 16489
You need to log in before you can comment on or make changes to this bug.