bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Updates are not being pushed for nightlies; partial .mar files not present

RESOLVED FIXED

Status

Release Engineering
General
RESOLVED FIXED
12 years ago
5 years ago

People

(Reporter: stevee, Assigned: rhelmer)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
Nightly firefox win builds (maybe other platforms too) after ~2007-03-09 are no longer receiving updates.

This looks like the last time where partial .mar files were generated.
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2007-03-08-04-trunk/

Subsequent builds do not have partial mars.
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2007-03-09-04-trunk/
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2007-03-10-04-trunk/
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2007-03-11-04-trunk/
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2007-03-12-04-trunk/
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2007-03-12-04-trunk/

Which, aiui, interferes with how the update.xml file is generated (left empty) so no updates are ever pushed, not even full ones.

Filing as per rhelmer in IRC. (cf not around to make a good job of filing :>)
(Reporter)

Updated

12 years ago
Assignee: nobody → build
Component: General → Build & Release
Product: Firefox → mozilla.org
QA Contact: general → preed
Version: Trunk → other
(Reporter)

Comment 1

12 years ago
Actually, if http://update-watch.localgho.st/nightly/production/latest/ is anything to go by, a lot of things look unhappy.
Besides just fixing whatever is causing the partials to not be generated this
time, there should be something that forces the full .mar file to get into AUS
if it is after X hours since it was generated and it has not yet been pushed to
AUS.

I think the not pushing it till the partial was done was put in to fix the
issue where people complained that they were on a low link (dial-up) and the
full update was getting pushed to them because it was available an hour earlier
than the partial and they would rather wait for the partial, but something
needs to be done so that the full update will be pushed anyway in the case
where something goes wrong building the partial.
(Assignee)

Comment 3

12 years ago
We pulled a bad update on Friday, and didn't remove the txt file that the nightly system looks for to determine where to get the complete from. That's removed now, I'll keep an eye on it and make sure it processes now.

The nightly update generation currently stops if any of the update paths fail for any reason - this used to be more important before the complete failover code was introduced into AUS (if the client is more than one partial behind, they get the complete update instead).

Given that I don't think it's really necessary to fail on these anymore, since one partial failure causes all partials for all products not to happen.
Assignee: build → rhelmer
(Assignee)

Comment 4

12 years ago
Looks like the nightly update generation script is completing successfully now.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.