Expose object attributes that describe type constraints

RESOLVED WONTFIX

Status

()

Core
Disability Access APIs
RESOLVED WONTFIX
12 years ago
7 years ago

People

(Reporter: Aaron Leventhal, Assigned: surkov)

Tracking

({access})

Trunk
access
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
Implement the proposal at http://wiki.mozilla.org/Accessibility/Datatypes

However, for now, the ARIA attribute is still called datatype, not type. If that changes I'll note it in this bug
(Reporter)

Updated

11 years ago
Duplicate of this bug: 390643
(Reporter)

Updated

11 years ago
Assignee: aaronleventhal → surkov.alexander
(Reporter)

Updated

11 years ago
Blocks: 376943
There is no aria-type or aria-datatype anymore; removing from ARIA tracker for now. Feel free to close, but we shouldn't forget about the wiki page if this comes up for ARIA 2.0.
No longer blocks: 343213
Actually there seems to be an non-ARIA component to this bug. Can someone elaborate what this bug is about?
(Assignee)

Comment 4

9 years ago
We do not expose datatype object attribute anymore (David, did you remove it, right?). Our doc said (https://developer.mozilla.org/en/Accessibility/AT-APIs/Gecko/Attrs) it is obsolete. We should say there it's not supported  and close this bug I think.
(Assignee)

Comment 5

7 years ago
wontfix per comment #4
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.