Method nsHTMLCanvasFrame::GetContentForEvent is useless

RESOLVED DUPLICATE of bug 292799

Status

()

Core
Canvas: 2D
--
trivial
RESOLVED DUPLICATE of bug 292799
11 years ago
11 years ago

People

(Reporter: Wladimir Palant (for Adblock Plus info Cc bugzilla@adblockplus.org), Assigned: Wladimir Palant (for Adblock Plus info Cc bugzilla@adblockplus.org))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

I noticed that nsHTMLCanvasFrame overrides GetContentForEvent but the implementation is identical to nsFrame::GetContentForEvent - with the exception of NS_ENSURE_ARG_POINTER check. From the look of it this method can be safely removed.
Created attachment 258376 [details] [diff] [review]
Untested patch

Removing nsHTMLCanvasFrame::GetContentForEvent and adding NS_ENSURE_ARG_POINTER to nsFrame::GetContentForEvent just in case.
Assignee: nobody → trev
Status: NEW → ASSIGNED
Severity: normal → trivial
Version: 1.8 Branch → Trunk

Updated

11 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 292799
You need to log in before you can comment on or make changes to this bug.