Inaccurate language name in getfirefox.com page

RESOLVED FIXED

Status

www.mozilla.org
General
RESOLVED FIXED
11 years ago
6 years ago

People

(Reporter: Håvard Mork, Assigned: reed)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
Reported by user to the nb-NO l10n team:

"
I wanted to dl Firefox 2. getfirefox.com links to
http://www.mozilla.com/en-US/firefox/all.html but the dropdown
in the bottom right corner had only "Norsk". This means
"Norwegian".

But just as there is no language "Canadian", there is no
language "Norwegian". In Canada you have English and French,
and Canadian usually means English. In Norway you have Bokmål
and Nynorsk - and Firefox is availavble in both. So please
link both
       Norsk Bokmål
       Norsk Nynorsk
to the appropriate files on
http://www.mozilla.com/en-US/firefox/all.html
"


Correcting the drop-down list box to "Norsk bokmål" would be nice. Secondly, if there are plans to offer both nb-NO and nn-NO downloads when visiting the site from a norwegian IP, that'd make things perfect. :-)
(Reporter)

Comment 1

11 years ago
a sidenode to this: 
The same user misunderstood the function of the drop-down list. The label for the list would for international users be more friendly if it said i.e. "Other languages for site:"

Comment 2

11 years ago
Pointing your web browser to http://getfirefox.com/ you will be forwarded to http://www.mozilla.com/en-US/firefox/

On this site you have a drop down at the bottom, and as explained by Håvard Mork in comment #1 - this is site language specific and is not a part of the real question raised in this bug.

When you reach the site http://www.mozilla.com/en-US/firefox/ you have a large green download button that makes you able to download Firefox 2.0 in "Norwegian (Bokmaal)". This is all good, but the problem is that we've had "Norwegian Nynorsk" as well since 2.0 - and a lot of our users would like to get their hands on that dialect insted. Few users will ever push the link below "Other Systems & Languages" to get it, so we need to make it more clear. Like we did on our own website http://firefox.no/ - There the user has a choice.

Also, when you eventually USE the drop down and choice Norsk as your language of choice on that site .. The download button doesn't even say bokmaal or nynorsk ... just "norsk", implementing bokmaal.

So we need two things to change. The norwegian users need to get both nn-NO and nb-NO as a choice on the english site, and both nn-NO and nb-NO as a choice on the norwegian site.
Like we already have for firefox.no

Comment 3

11 years ago
Side note about user-agent:
Mozilla/5.0 (Windows; U; Windows NT 5.1; nb-NO; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

This gives me the english version of mozilla.com with norwegian bokmaal downloads.
Has nn-NO is a lot smaller then nb-NO and NO often is confused just to be nb-NO, we need to get nn-NO more out of the dark.

Comment 4

11 years ago
Reed, Pascal -- can you review this bug and suggest solutions for both the en-US mozilla.com site and the no mozilla-europe.org site?
Funny, I solved this problem yesterday night for Mozilla Europe and it will be published in a few days :)

So, the current situation on mozilla Europe is :
- dropdown list that says Norsk bokmål
- two download boxes on the Norwegian Firefox page, one for nynorsk, one for bokmål

I will add the nynorsk download box on the front page as well, I just have to find a way to make it not too cluttered
The Nynorsk download box is now on moz.eu firefox download page and the dropdown says Norsk bokmål
http://www.mozilla-europe.org/no/products/firefox/
now on moz-eu frontpage as well

Comment 8

11 years ago
Looks good. Thanks for the update Pascal. Still need it changed for "GetFirefox.com" ... Your solution might be copied by Reed?

Also .. I actually tried http://moz.eu/ for fun (your comment #6) ... That domain seems to be available from someone :)

Comment 9

11 years ago
Ronny: we're investigating a change to the design of the download button that will allow us to display both nn-NO and nb-NO download options in a single button, rather than having two buttons displayed on the page. 

Comment 10

11 years ago
What about the solution we have @ www.firefox.no for that?

Comment 11

11 years ago
Adding Steven Garrity and John Slater to the bug.

Ronny: your solution on firefox.no seems effective. We need to adapt an approach similar to yours that will integrate with the visual design of mozilla.com.
(Assignee)

Updated

11 years ago
Assignee: nobody → reed
OS: Windows XP → All
Hardware: PC → All
(Assignee)

Comment 12

11 years ago
I think I have a potential fix for this. I'll do some testing and let you know if it works.
Status: NEW → ASSIGNED
(Assignee)

Comment 13

11 years ago
It works! Whee!

So, this has been fixed on the trunk. The fix will be pushed tomorrow during the Firefox 1.5.0.11 / 2.0.0.3 release. :)
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 14

11 years ago
Nice work Reed! Still looking at a solution that collapse nn-NO and nb-NO into a single button, but this interim fix addresses Håvard's bug report.
Should we go for a new bug to track merging multiple locales into one button?

The complication here is that the entire green button is clickable (which is great, for most cases). We could probably have the javascript be a bit smarter and  present an alternate setup (non-clickable) box with multiple links inside it when there is more than one locale.

Thoughts?

There's actually a windows machine here at our office that see's both en-US and en-GB for some reason, and we have the same double-button situation.
You can create a new bug indeed.

Note that on mozilla europe we don't use javascript but php to generate the links (using javascript for that on mozilla.com looks kind of a hack to me ;p ).

I would be in favour of a different dialog bog that is not entirely clickable. I am not quite happy with the current big-box-as-a-link solution because it lacks flexibility for Mozilla europe. For instance I would like to be able to generate a box with three rows for a language to give the three download links, one per OS. Some kind of stacking mechanism, each row could be a rollover link area.

I would also prefer a box that extends horizontally to a certain extent when the box is two narrow for the content (min-width and max-width values). We have many download boxes where 'download now' is split on two lines on Mozilla Europe).

Comment 17

11 years ago
Adjusting download.js on mozilla.com so the entire button isn't a link for multiple locales sounds like a good solution interim Steven. I'm guessing Reed can help with adjusting download.js...
New (In reply to comment #16)
> You can create a new bug indeed.

New bug created: #374797
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.