Last Comment Bug 373818 - Default Plug-in's InfoPlist.strings is a broken .strings file (typos)
: Default Plug-in's InfoPlist.strings is a broken .strings file (typos)
Status: VERIFIED FIXED
: verified1.8.1.4
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: unspecified
: PowerPC Mac OS X
: -- normal (vote)
: ---
Assigned To: Smokey Ardisson (offline for a while; not following bugs - do not email)
:
: Benjamin Smedberg [:bsmedberg]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-13 14:26 PDT by Smokey Ardisson (offline for a while; not following bugs - do not email)
Modified: 2007-05-08 17:00 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Corrected InfoPlist.strings (616 bytes, application/octet-stream)
2007-03-13 14:26 PDT, Smokey Ardisson (offline for a while; not following bugs - do not email)
jaas: review+
pavlov: superreview+
dveditz: approval1.8.1.4+
Details

Description Smokey Ardisson (offline for a while; not following bugs - do not email) 2007-03-13 14:26:04 PDT
Created attachment 258462 [details]
Corrected InfoPlist.strings

Default Plug-in's InfoPlist.strings file contains doubled double quotes at the beginning of two different strings, which throws errors in AppleGlot because the .strings file is not valid.

I don't think Firefox builds Default Plug-in, so it would be nice to get this on the branch if possible to cut down on the error noise our Camino l10n teams are seeing. 

(This is a UTF-16 file, as always, but cvs/bonsai/diff/etc. can't hack UTF-16, so it needs to pretend to be binary in all those cases.)
Comment 1 Josh Aas 2007-03-13 14:59:18 PDT
This is for the file at:

mozilla/modules/plugin/samples/default/mac/English.lproj/InfoPlist.strings
Comment 2 Josh Aas 2007-03-13 18:01:53 PDT
checked in on trunk
Comment 3 Samuel Sidler (old account; do not CC) 2007-03-13 18:21:49 PDT
Comment on attachment 258462 [details]
Corrected InfoPlist.strings

Requesting approval for the 1.8 branch on this patch to a default plug-in which Firefox doesn't currently build. afaict, this patch only affects Camino. See comment 1 for where it's located. Also note that it only changes a "" to a ".
Comment 4 Daniel Veditz [:dveditz] 2007-03-29 11:32:02 PDT
Comment on attachment 258462 [details]
Corrected InfoPlist.strings

approved for 1.8.1.4, a=dveditz for release-drivers
Comment 5 froodian (Ian Leue) 2007-03-29 11:58:36 PDT
Checked in on MOZILLA_1_8_BRANCH.

/cvsroot/mozilla/modules/plugin/samples/default/mac/English.lproj/InfoPlist.strings,v  <--  InfoPlist.strings
new revision: 1.2.76.1; previous revision: 1.2
Comment 6 Samuel Sidler (old account; do not CC) 2007-05-08 17:00:04 PDT
Verified on branch and trunk. Note again that this bug occurs in core but only affects Camino.

Note You need to log in before you can comment on or make changes to this bug.