Closed Bug 373825 Opened 14 years ago Closed 13 years ago

"Open all in tabs" menu item in bookmarks menu causes data loss

Categories

(Firefox :: Tabbed Browser, defect)

x86
Windows Vista
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jpiper, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

Selecting an "Open all tabs" menu item from the bookmarks menu
a) Discards any currently open tabs
b) Does so without warning, regardless of the value of browser.tabs.warnOnClose
c) Does not make the closed tabs available in the "Recently Closed Tabs" menu for recovery

Reproducible: Always

Steps to Reproduce:
1) Open a page with a text area.
2) Enter any data
3) Select the "Open all tabs" menu item
Actual Results:  
The data in the text area is irretrievably lost

Expected Results:  
One or more of the following:

a) The browser does NOT close open tabs
b) The browser observes browser.tabs.warnOnClose and prompts before closing open tabs
c) The browser makes the closed tabs recoverable
justin has a point, when loading all tabs, we are closing tabs.

but, we aren't heeding the warn on close pref.

Status: UNCONFIRMED → NEW
Ever confirmed: true
This is very similar to bug 300198 / bug 216346.
Those led me to bug 175124, which does appear to be implemented. Re-used tabs add to the history, and closed tabs appear in the "Recently Closed Tabs" menu. I would be okay with resolving this invalid, but I think if you're going to leave the current behavior, something needs to be done to improve discoverability.

The tabs I had open already had history, so I didn't notice that the back button worked, and since the "Recently Closed Tabs" didn't have all of the closed tabs I expected, I assumed the ones I could find were duplicates that I had closed on my own and that the rest had been lost.

My reaction was to close all the tabs Firefox "opened", and re-opened what few I could find in "Recently Closed Tabs". The end result being that, in spite of what protection the browser provides, I lost data anyway.

There is also still a problem when more than ten tabs are closed. Only the first ten plus one for each bookmark opened are recoverable in that case.
Odd - this behavior has been around for what seems like a long time, yet I finally got fed up enough today and was just going to open the bug when I found out it was opened 2 weeks ago...

Anyway, WHY are we closing/reusing tabs?  I have a bookmark folder with 4 items in them, I have 2 tabs open - when I click "Open All In Tabs" I expect to have 7 tabs open... otherwise you force me to open up another window, which I don't want to do.  What would be wrong with keeping existing tabs open?
uh, some problem with my math there, but you get the idea - I vote for append always and having read Bug 216346 I have set my preferences as such.  But in any case, I don't think Firefox should EVER close my tabs when I'm trying to open other tabs.  That is so counterintuitive and it's clear from Bugs like 300198 and 175124 and discussions here http://groups.google.com/group/mozilla.dev.apps.firefox/browse_thread/thread/82d923d73aff4b51/7294562ce8751a99#7294562ce8751a99 that at least some people agree with me.

It sounds like Mike Connor has it in his plans to update this behavior in a "proper" way - but not sure where the bug is for that.  Can this bug be used to track it?
This thread was made in March and it is not July. Why hasn't it been resolved yet?

Selecting "Open all in tabs" over-writes all previously opened tabs to load the new windows, even if a new tab has been opened.

Version: 2.0.0.5
(In reply to comment #6)
> This thread was made in March and it is not July. Why hasn't it been resolved
> yet?
> 
> Selecting "Open all in tabs" over-writes all previously opened tabs to load the
> new windows, even if a new tab has been opened.
> 
> Version: 2.0.0.5

This works for me using trunk build Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b2pre) Gecko/2007121016 Minefield/3.0b2pre

See bug 403074 for more information.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.