bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

autoconfig (MCD) doesn't work anymore in thunderbird 2.0

RESOLVED INVALID

Status

Thunderbird
Build Config
--
major
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Laurent Bauvens, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Thunderbird version 2.0pre (20070312)

autoconfig works fine in 1.5.x.x versions of Thunderbird. The same configuration applied on Thunderbird 2.0 Pre doesn't do nothing.

Reproducible: Always

Steps to Reproduce:
1.configure autoconfig in all.js file
  pref("general.config.obscure_value", 0); // for MCD .cfg files
  pref(general.config.filename", "thunderbird.cfg"); // for MCD .cfg files

2.configure log environment variables
  NSPR_LOG_FILE=C:\TB_LOG.TXT
  NSPR_LOG_MODULE=MCD:5

3.make a thunderbird.cfg in the application directory
//BEGIN CE Prefs
lockPref("general.config.vendor","thunderbird");
lockPref("autoadmin.global_config_url","http://127.0.0.1/thunderbird.jsc");
4.put a thunderbird.jsc file on the web server
5. run thunderbird 
6. close thunderbird
7. delete the thunderbird.cfg file
8. run thunderbird again
 

Actual Results:  
* web server and thunderbird's log files are empty.
* nothing appends
* without thunderbird.cfg file, thunderbird starts normally !
--> autoconfig doesn't work

Expected Results:  
* log files show thunderbird.jsc download
* configuration keys in the thunderbird.jsc must be included in the prefs.js file
* in case of "thunderbird.cfg" file doesn't exist, thunderbird must stop start process and display an error dialog box, and then it closes itself.

Comment 1

12 years ago
Just in case, are you sure it's not due to a typo ?.

i.e. quote missing in
  pref(general.config.filename", "thunderbird.cfg");
       ^
or missing plural in
  NSPR_LOG_MODULE=MCD:5
                 ^

As TB 2 autoconfig works in my setup -- had an "thunderbird.cfg" data encoding issue on Windows but NSPR log mentionned it.

Comment 2

12 years ago
I know it's working for one large site we're deployed at...I'm not sure what's going on at your site.
(Reporter)

Comment 3

12 years ago
(In reply to comment #1)
> Just in case, are you sure it's not due to a typo ?.
> 
> i.e. quote missing in
>   pref(general.config.filename", "thunderbird.cfg");
>        ^

You're right, I made a mistake. It works much better with this quote.
Logs are OK, thunderbird.cfg is read and thunderbird.jsc is downloaded.
all is fine.
Thanks.


Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 4

12 years ago
Maybe we could learn from your problem and have a better "error handling system" in MCD. I find it quite difficult to debug, as errors and warnings are often simply "muted".
FIXED is reserved for changes in the Mozilla code base; changing resolution to INVALID.
Resolution: FIXED → INVALID
You need to log in before you can comment on or make changes to this bug.