Cannot iterate through search results

RESOLVED WORKSFORME

Status

()

Bugzilla
Bugzilla-General
--
minor
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: C. Matsuoka, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2) Gecko/20061201 Firefox/2.0.0.2 (Ubuntu-feisty)
Build Identifier: 2.23.3+

This was reported in the Mandriva bugzilla by Sebastian Trüg (strueg.at.mandriva.com) (link to the original report in the URL field) and is being sent upstream.

Original report:

When I query a list of bugs via the search option I can only use the "next" or
"prev" button once. Afterwards they are greyed out. If I, however, post a
comment on a bug I am forwarded to the next bug including the next and prev
buttons.

Reproducible: Always

Steps to Reproduce:
1. Perform a search such querying user's own bugs
2. Pick a bug from results list. Next/prev links are not available.
3. Add a comment.
Actual Results:  
The next bug in the list is shown and navigation works.

Expected Results:  
Next/prev links should work in step 2 above.
(Reporter)

Comment 1

11 years ago
This can be a manifestation of Bug 359943.
I couldn't reproduce this on current 2.22, 3.0 or trunk branches. First, Last, Next, Prev and "Show last search results" links all work as long as a BUGLIST cookie is correctly saved and returned. Please, make sure cookies are enabled and allowed on your browser and that a correct cookiedomain/cookiepath parameters are set.

I can see this problem in Mandriva Bugzilla that runs 2.23.3+ version. However, couldn't reproduce with a stock 2.23.3 version either so maybe this is because of some local customization? Also you should upgrade to 3.0rc1 as that might fix this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.