Compilation problem: invalid conversion from `WCHAR*' to `WORD*'

RESOLVED DUPLICATE of bug 373010

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 373010
11 years ago
11 years ago

People

(Reporter: Sergey Fukanchik, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.10) Gecko/20070216 Firefox/1.5.0.10
Build Identifier: 

I checked sources from cvs and building thunderbird for windows using mingw/cygwin, w32api 3.8.

When compilation reaches GFX, build fails with following error.

cvs update didn't help.

Reproducible: Always

Steps to Reproduce:
See http://developer.mozilla.org/en/docs/Build_Documentation
Actual Results:  
Error:
c:/mozilla/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp: In function `PRBool IsMissingGlyphsGDI(HDC__*, const char*, PRUint32, WCHAR*)':
c:/mozilla/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp:647: error: invalid conversion from `WCHAR*' to `WORD*'
c:/mozilla/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp: In function `PRBool IsMissingGlyphsGDI(HDC__*, const PRUnichar*, PRUint32, WCHAR*)':
c:/mozilla/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp:664: error: invalid conversion from `WCHAR*' to `WORD*'


Expected Results:  
gfx to be compiled.

Looking at line 664 i see following call:

GetGlyphIndicesA(aDC, aString, aLength, glyphBuffer, GGI_MARK_NONEXISTING_GLYPHS);

glyphBuffer here is WCHAR*, but in wingdi.h it is defined as:
WINGDIAPI DWORD WINAPI GetGlyphIndicesA(HDC,LPCSTR,int,LPWORD,DWORD);
and LPWORD is expected! Next i go to http://msdn.microsoft.com/library/default.asp?url=/library/en-us/gdi/fontext_4svn.asp
and see LPWORD there too (not WCHAR*).

Sorry if i filed this bug to wrong place.
Assignee: general → nobody
Component: GFX → GFX: Thebes
QA Contact: ian → thebes

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 373010
You need to log in before you can comment on or make changes to this bug.