[I18n] Japanese Profile name from 4.x is not displayed correctly and migration fails

VERIFIED FIXED in M17

Status

Core Graveyard
Profile: Migration
P3
normal
VERIFIED FIXED
18 years ago
2 years ago

People

(Reporter: Teruko Kobayashi, Assigned: racham)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+] ETA:7/11)

(Reporter)

Description

18 years ago
When you create Japanese Profile name in Communicator 4.x (I used 4.72), the 
Japanese Profile name is displayed as garbage in Netscape6's Profile Manager.

Steps of reproduce
1. Use Communicator 4.x to create Japanese Profile name
2. Start Netscape6's Profile Manager 

Actual result
Japanese Profile name is displayed as garbage in the Profile Manager

Expected result
Japanese Profile name is diaplayed correctly in Japanese Windows.

Tested 2000042709 Win32 build.
(Reporter)

Comment 1

18 years ago
Changed QA Contact to teruko@netscape.com
QA Contact: gbush → teruko
Summary: [I18n] Japanese Profile name from 4.x is not displayed correctly → [I18n] Japanese Profile name from 4.x is not displayed correctly

Comment 2

18 years ago
Could this be a migration issue because 4.x uses native encoding (e.g., SJIS
for Japanese profile names on Windows) and 6.0 uses UTF-8?

Comment 3

18 years ago
This realy should be nsbeta2 since when profile names are in Japanese
as described above, migration will not proceed and simply quit  when
 you give a go-ahead to the prompt to migrate the 4.x profile.
Thus if you have an older profile named in Japanese, no migration is
possible for that profile.
Nominating for nsbeta2.
Keywords: nsbeta2

Updated

18 years ago
Summary: [I18n] Japanese Profile name from 4.x is not displayed correctly → [I18n] Japanese Profile name from 4.x is not displayed correctly and migration fails

Comment 4

18 years ago
Putting on [nsbeta2+] radar for beta2 fix.
Whiteboard: [nsbeta2+]

Comment 5

18 years ago
dbragg is out on sabbatical till 6/6, so this won't make into next tuesday m16
Target Milestone: --- → M17

Comment 6

18 years ago
Actually this is a Profile Manager issue, not a Profile Migration issue.  (At 
least not yet :-)

Reassigning to Bhuvan.
Assignee: dbragg → racham
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 7

18 years ago
I tested this in 2000-06-27-08 Win32 build.  
After I created the Japanese profile and I tried to run the profile in 
Netscape6,

message in the console,   
"Inside Migrate Profile routine.
JavaScript error:
 line 0: uncaught exception: [Exception... "Component returned failure code: 0x8
0004005 (NS_ERROR_FAILURE) [nsIProfile.migrateProfile]"  nsresult: "0x80004005 (
NS_ERROR_FAILURE)"  location: "JS frame :: chrome://communicator/content/profile
/profileSelection.js :: onStart :: line 160"  data: no]"

then, the Japanese profile did not run in Netscape6.
(Assignee)

Updated

18 years ago
Whiteboard: [nsbeta2+] → [nsbeta2+] ETA:7/11
(Assignee)

Comment 8

18 years ago
Fixed. 

So, the next level changes are in profile migration's code. Don Bragg owns a bug    
(44764) to address that problem.

All macintosh issues should be addressed in the bug 45183.

Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

18 years ago
I verified this in 2000-07-12-09 Win32 build.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.