Using tabs with "Show the New Tab Button on Tab Bar" crushes all tabs to far left

VERIFIED WORKSFORME

Status

()

--
major
VERIFIED WORKSFORME
12 years ago
11 years ago

People

(Reporter: antique9, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME - 09/07)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

I experienced this bug when first starting up Firefox 2.0.0.2. Upon hitting Command-T for a new tab, all of the visible browser windows were pushed to the far left 1/2" of the window. All that was visible was a very thin column of the new tab, the New Tab tab bar button, and next/last tab buttons. Upon turning off the "Show the new Tab Button on the tab bar" in Preferences -> Tabbed Browsing -> Display Options, the tabs were able to stretch out to a usable size. I wish I could affix a screenshot...

Reproducible: Always

Steps to Reproduce:
1.Go to Preferences -> Tabbed Browsing -> Display Options
2.Select "Show the new tab button on the tab bar"
3.You may not even need to create a new tab for your visible browser window to get pushed to the far left, leaving a large, white, unusable space.
Actual Results:  
The active browser tab was pushed to the far left of the screen.

Expected Results:  
Opened a new tab, without pushing all tabs to the far left.

about:buildconfig

Build platform
target
powerpc-apple-darwin8.7.0

Build tools
Compiler 	Version 	Compiler flags
gcc-3.3 -arch ppc 	gcc version 3.3 20030304 (Apple Computer, Inc. build 1819) 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align -Wno-long-long -nostdinc -isystem /Developer/SDKs/MacOSX10.2.8.sdk/usr/include/gcc/darwin/3.3 -isystem /Developer/SDKs/MacOSX10.2.8.sdk/usr/include -F/Developer/SDKs/MacOSX10.2.8.sdk/System/Library/Frameworks -fpascal-strings -no-cpp-precomp -fno-common -I/Developer/SDKs/MacOSX10.2.8.sdk/Developer/Headers/FlatCarbon
g++-3.3 -arch ppc 	gcc version 3.3 20030304 (Apple Computer, Inc. build 1819) 	-fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -nostdinc -nostdinc++ -I/Developer/SDKs/MacOSX10.2.8.sdk/usr/include/gcc/darwin/3.3/c++ -I/Developer/SDKs/MacOSX10.2.8.sdk/usr/include/gcc/darwin/3.3/c++/ppc-darwin -I/Developer/SDKs/MacOSX10.2.8.sdk/usr/include/gcc/darwin/3.3/c++/backward -isystem /Developer/SDKs/MacOSX10.2.8.sdk/usr/include/gcc/darwin/3.3 -isystem /Developer/SDKs/MacOSX10.2.8.sdk/usr/include -F/Developer/SDKs/MacOSX10.2.8.sdk/System/Library/Frameworks -fpascal-strings -no-cpp-precomp -fno-common -fshort-wchar -I/Developer/SDKs/MacOSX10.2.8.sdk/Developer/Headers/FlatCarbon -I/usr/X11R6/include

Configure arguments
--target=powerpc-apple-darwin8.7.0 --with-macos-sdk=/Developer/SDKs/MacOSX10.2.8.sdk --enable-application=browser --enable-update-channel=release --enable-official-branding '--enable-optimize=-O2 -g' --disable-debug --disable-tests --enable-update-packaging --enable-static --disable-shared --enable-prebinding --enable-svg --enable-canvas
Build platform
target
i386-apple-darwin8.7.0

Build tools
Compiler 	Version 	Compiler flags
gcc-4.0 -arch i386 	gcc version 4.0.1 (Apple Computer, Inc. build 5250) 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align -Wno-long-long -isysroot /Developer/SDKs/MacOSX10.4u.sdk -fpascal-strings -no-cpp-precomp -fno-common -I/Developer/SDKs/MacOSX10.4u.sdk/Developer/Headers/FlatCarbon
g++-4.0 -arch i386 	gcc version 4.0.1 (Apple Computer, Inc. build 5250) 	-fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -isysroot /Developer/SDKs/MacOSX10.4u.sdk -fpascal-strings -no-cpp-precomp -fno-common -I/Developer/SDKs/MacOSX10.4u.sdk/Developer/Headers/FlatCarbon

Configure arguments
--target=i386-apple-darwin8.7.0 --with-macos-sdk=/Developer/SDKs/MacOSX10.4u.sdk --enable-application=browser --enable-update-channel=release --enable-official-branding '--enable-optimize=-O2 -g' --disable-debug --disable-tests --enable-update-packaging --enable-static --disable-shared --enable-svg --enable-canvas

Comment 1

11 years ago
Reporter, are you still able to reproduce with a more recent build of Firefox? If not, could you please resolve this bug WORKSFORME? Thanks.
Whiteboard: CLOSEME 08/09
(Reporter)

Comment 2

11 years ago
Created attachment 274072 [details]
Screengrab of "crushed" tabs
(Reporter)

Comment 3

11 years ago
I'm now using version 2.0.0.5 and it's still happening. Screenshot now attached.
Dustin, can you reproduce this with a new profile? This looks like a problem with an extension.

http://kb.mozillazine.org/Profile_Manager
Whiteboard: CLOSEME 08/09 → CLOSEME - 08/30
(Reporter)

Comment 5

11 years ago
I created a new profile and was not able to reproduce the bug.
Dustin,

This is likely due to a problem extension. Feel free to go through and determine which extension is causing the problem by disabling them one by one or by migrating files to the new profile and seeing which file caused the problem. If you don't wish to do either of those, please close this bug as WORKSFORME.
Whiteboard: CLOSEME - 08/30 → CLOSEME - 09/07
(Reporter)

Comment 7

11 years ago
Closing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Thanks Dustin.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.