crashes when clicking on shop.netscape.com

VERIFIED DUPLICATE of bug 36862

Status

()

P1
critical
VERIFIED DUPLICATE of bug 36862
19 years ago
19 years ago

People

(Reporter: namachi, Assigned: gagan)

Tracking

({crash})

Trunk
x86
Windows NT
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Steps to Reproduce :-

 1) Go to http://shop.netscape.com/electronics/mobile.adp
 2) Click on Cellphone Add.
 3) Crashes Immediately.
(Reporter)

Comment 1

19 years ago
Stack Trace :

nsIOService::NewChannelFromURI 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsIOService.cpp, line 225] 
NS_OpenURI [..\..\dist\include\nsNetUtil.h, line 104] 
nsDocShell::DoURILoad [d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, 
line 2516] 
nsDocShell::InternalLoad 
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 2291] 
nsWebShell::HandleLinkClickEvent 
[d:\builds\seamonkey\mozilla\webshell\src\nsWebShell.cpp, line 1026] 
OnLinkClickEvent::HandleEvent 
[d:\builds\seamonkey\mozilla\webshell\src\nsWebShell.cpp, line 915] 
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 576] 
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 
1032] 
USER32.dll + 0x1820 (0x77e71820) 

Comment 2

19 years ago
repro on 2000042708 win98.

gpf:

MOZILLA caused an invalid page fault in
module NECKO.DLL at 0167:605fa54c.
Registers:
EAX=0068f920 CS=0167 EIP=605fa54c EFLGS=00010246
EBX=00000000 SS=016f ESP=0068f90c EBP=0068f92c
ECX=0068f91c DS=016f ESI=80000000 FS=132f
EDX=0068f950 ES=016f EDI=00000000 GS=0000
Bytes at CS:EIP:
8b 0f ff 51 14 be 00 00 00 80 85 c6 74 04 8b f0 
Stack dump:
00000000 0068f920 80000000 80000000 60d317f4 00000000 00000001 0068f954 
0068f954 60b1471e 00860920 00000000 0068f950 80000000 00000000 02673630 
Keywords: crash
(Reporter)

Comment 3

19 years ago
Adding chofmann and leger into CC list.
Priority: P3 → P1
(Reporter)

Comment 4

19 years ago
Java Script Code for link :-

<DIV bgcolor="#FFFFFF">
<A 
HREF="/ams/clickThruRedirect.adp?55005456,6188199,http://ephones.com/manufacture
rs/productview.asp?PRODUCTID=1000354&amp;CATALOGID=934&amp;REF=EPP-NSCP-0112"  
onmouseover="mURL=this.href; return true;"  onclick="ToolbarJump(mURL); return 
false;"  ><img src="/PromoArt/ep_sch3500da_0417-0012.gif.237260.1.gif" 
width="143" height="245" border="0" alt="ePhones.com: SCH3500 In Stock 
Now!"></a> 
</DIV>

Comment 5

19 years ago
This is a dup of bug 36862, the stacktrace looks exactly the same. When clicking
on a link that does not resolve to a valid URL and we fail trying to create the
URL, the resulting error is not checked, the null-URI is forwarded to some
functions that do not like null-URIs at all.

*** This bug has been marked as a duplicate of 36862 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 6

19 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.