Closed Bug 374023 Opened 14 years ago Closed 1 year ago

Inclusion of <script src=""></script> makes Mozilla load page twice

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 1299373

People

(Reporter: nils.lastein, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; da; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; da; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

Inclusion of <script src=""></script> in html head makes Mozilla hit the webserver twice with the same URL.

<HTML><head><TITLE></TITLE>
<script src=""></script>
</head>
<BODY>
</BODY>
</HTML>


Reproducible: Always

Actual Results:  
dual webserver hit

Expected Results:  
single webserver hit
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 225554
Re-opening and changing to NEW, because double HTTP GET with <script src=""> is still observed in Bug 387078.  

As seen in Bug 387078, double HTTP GET with <script src=""> is observed even after fix of Bug 444931 to which this bug was indirectly DUP'ed.
  1. This bug(<script src="">) was closed as DUP of Bug 225554(<img src="")
  2. Many bugs were also closed as DUP of Bug 225554(<img src="").
  3. Bug 225554 was closed as DUP of Bug 444931(<img src=""), and FIXED.

DUPing of this bug to Bug 225554 was incorrect action?
Or care for this bug's case(<script src="">) was lost by indirect DUPing?

Or "double HTTP GET" we observed in Bug 387078 is simply <script src=""> version of Bug 497665?
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true
Seems like it is fixed in the latest version of firefox.
Can you please update the bug ?
Flags: needinfo?(nils.lastein)
Status: NEW → RESOLVED
Closed: 14 years ago1 year ago
Flags: needinfo?(nils.lastein)
Resolution: --- → DUPLICATE
Duplicate of bug: 1299373
You need to log in before you can comment on or make changes to this bug.