Camino hangs when I try to show the "More than one week ago" history

RESOLVED DUPLICATE of bug 393647

Status

Camino Graveyard
History
--
critical
RESOLVED DUPLICATE of bug 393647
11 years ago
6 years ago

People

(Reporter: Håkan Waara, Unassigned)

Tracking

({hang})

1.8 Branch
PowerPC
Mac OS X

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
Version 2007022310 (1.1b)

I have a big history, and hadn't used this computer for a while. When I tried to find a page in my History, everything hung. I force-quitted, and tried again - same result. 

It's reproducible every time.

I can show the history in the History manager just fine, but when using the menu (History > More than one week ago) everything hangs.

My "More than one week ago" folder in the history manager says there are 30858 items.

I couldn't Shark it (Shark crashed), but I'll attach a sample from Sampler.app
(Reporter)

Comment 1

11 years ago
Created attachment 258688 [details]
Sampler.app report
(Reporter)

Comment 2

11 years ago
Created attachment 258689 [details]
The raw trace data (can be opened and analyzed with Sampler.app)
(Reporter)

Comment 3

11 years ago
I'm not sure how accurate the trace is, but it looks like it could be the bonjour notifications that are killing it?
So, smfr "originally" limited the History menu menus to 100 items (bug 291414 comment 14) in May 2005, but at some point (after alternates?) we lost that limit.

In November of 2007, froodian fixed this limit in bug 393647, so Håkan filed this while the limit had been removed, making it, in essence, a dupe of that bug.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 393647
You need to log in before you can comment on or make changes to this bug.