lower-case $(topsrcdir) no longer works (error: "--enable-application=APP is required" when running configure manually)

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
12 years ago
8 months ago

People

(Reporter: ben, Assigned: benjamin)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

I am trying to build the firefox 2.0 on Windows XP for my debug. I
have modified the mozconfig file under c:/mozilla/browser\config. Here
is its contents:

. $topsrcdir/browser/config/mozconfig
mk_add_options MOZ_CO_PROJECT=browser
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/browser/ff-dbg
ac_add_options --enable-application=browser
ac_add_options --diable-optimize
ac_add_options --enable-debug
ac_add_options --diable-static --enable-shared
ac_add_options --diable-tests

Under the mozilla dir in the building shell,  I exported the
environment variable:
export MOZCONFIG=/c/mozilla/browser/config
then ran command configure, I got an error:

error: --enable-application=APP is required



Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Please read the build instructions at http://mozilla.org/build. You should be using make -f client.mk, not configure.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
(Assignee)

Comment 2

12 years ago
This is a perfectly good way to build the app. The problem is that I broke $(topsrcdir). $(TOPSRCDIR) still works.
Status: RESOLVED → UNCONFIRMED
Component: Build Config → Build Config
Product: Firefox → Core
Resolution: INVALID → ---
(Assignee)

Updated

12 years ago
Assignee: nobody → benjamin
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: build.config → build-config
Summary: building system breaks with an error: "--enable-application=APP is required" when running the command configure → lower-case $(topsrcdir) no longer works (error: "--enable-application=APP is required" when running configure)
Summary: lower-case $(topsrcdir) no longer works (error: "--enable-application=APP is required" when running configure) → lower-case $(topsrcdir) no longer works (error: "--enable-application=APP is required" when running configure manually)
(Reporter)

Comment 3

12 years ago
In which files I need to change the lower-case $(topsrcdir) to $(TOPSRCDIR)?
All the makefiles?
I did change this in the c/mozilla/browser/mozconfig, then copy it to /c/mozilla/.mozconfig

run in my build shell
export MOZCONFIG=/c/mozilla/browser/config 

then run either ./configure or make client.mk build.
Either doesn't work and has the same error.

error: --enable-application=APP is required

(Assignee)

Comment 4

11 years ago
I can't reproduce this bug.
Status: NEW → RESOLVED
Last Resolved: 12 years ago11 years ago
Resolution: --- → WORKSFORME
I case someone finds this bug by searching for the error in the subject line (it's the only one currently), another possible cause is that you did not set MOZCONFIG to an absolute path.

Updated

8 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.