when above link is view in mozilla, it displays properly, but the link is wrong

VERIFIED FIXED

Status

()

Core
Layout
P3
critical
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: luke_harless, Assigned: rickg)

Tracking

({crash})

Trunk
x86
Windows 98
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)
BuildID:    2000041805

Link should be luke@despammed.com, instead it's
luke@despammed.co&#109

Reproducible: Always
Steps to Reproduce:
put above mailto code in html page, load in Mozilla

Actual Results:  Display properly, but link is luke@despammed.co&#109

Expected Results:  link is luke@despammed.com
(Reporter)

Comment 1

18 years ago
Grrr. the url field renders html.  Put <a></a> around the code below.

href=mailto:&#108;&#117;&#107;&#101;&#64;&#100;&#101;&#115;&#112;&#97;&#109;&#10
9;&#101;&#100;&#46;&#99;&#111;&#109>&#108;&#117;&#107;&#101;&#64;&#100;&#101;&#1
15;&#112;&#97;&#109;&#109;&#101;&#100;&#46;&#99;&#111;&#109

Comment 2

18 years ago
I crash when clicking the Bugzilla-created URL link on 20000042708 win98.

gpf:

MOZILLA caused an invalid page fault in
module NECKO.DLL at 0167:605fa54c.
Registers:
EAX=0068f920 CS=0167 EIP=605fa54c EFLGS=00010246
EBX=00000000 SS=016f ESP=0068f90c EBP=0068f92c
ECX=0068f91c DS=016f ESI=80000000 FS=1367
EDX=0068f950 ES=016f EDI=00000000 GS=5567
Bytes at CS:EIP:
8b 0f ff 51 14 be 00 00 00 80 85 c6 74 04 8b f0 
Stack dump:
00000000 0068f920 80000000 80000000 60d317f4 00000000 00000001 0068f954 
0068f954 60b1471e 00860920 00000000 0068f950 80000000 00000000 02673670 

Talkback data has been sent in.  Incident ID is TB9497499Q
Severity: normal → critical
Keywords: crash

Comment 3

18 years ago
On 20000042708 NT luke_harless@ibm.net's first example doesn't work, but the 
second certainly does render incorrectly. No crash, however. Changing bug status 
to new.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

18 years ago
I can't reproduce the problem with the sample code provided. The mailto link 
renders correctly and opens messenger with the default email assigned. Tested 
with the May 01 build (2000050111).
(Reporter)

Comment 5

18 years ago
Build 20000050208 still renders incorrectly.
Look at http://members.xoom.com/Luke_H/mailtotest.html for better example.

Comment 6

18 years ago
The content model is wrong
Assignee: rickg → harishd
(Assignee)

Comment 7

18 years ago
I already have a fix for this. 
Assignee: harishd → rickg
(Assignee)

Comment 8

18 years ago
Fixed by change to nsHTMLContentSink::ReduceEntities().
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 9

18 years ago
Verified fixed in (Win 32, Mac 0S 9, and Linux) May 22nd builds.
Status: RESOLVED → VERIFIED
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.