Closed Bug 374171 Opened 13 years ago Closed 12 years ago

Past sorts of messages are not remembered as new sorts are done

Categories

(SeaMonkey :: MailNews: Message Display, enhancement)

x86
Windows XP
enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 57898

People

(Reporter: cfleming2691, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.2) Gecko/20070222 SeaMonkey/1.1.1
Build Identifier: SeaMonkey/1.1.1

If my mail messages are sorted by date from the most recent message to the least recent message and then I sort my messages by sender, the messages for each sender are listed from the least recent to the most recent. 
There should be a hierarchy operating on the sorting operation so
that the messages are sorted on the current sort request field, but once this sort is done the messages should be further sorted by the prior sort that were done.

For example I have done the following 3 sorts.
1. Date from most recent to least recent
2. Subject from A to Z
3. Sender from Z to A

My messages should be sorted firstly sorted by sender from Z to A

Next the messages for each sender should be sorted by subjext from A to Z

Finally the messages for each subject should be sorted by date from most recent to least recent.

This is basic functionality that exist in outlook express etc and it makes it hard trying to use seamonkey and not be able to sort messages in the correct order

Reproducible: Always

Steps to Reproduce:
Test requires multiple dated messages from 2 people

1.sort messages from most recent to least recent

2.Sort messages by user

The sorted messages for each sender go from least recent to most recent and not a the sort in step 1
3.
Actual Results:  
The sorted messages from each sender go from the least recent to most recent. 

Expected Results:  
The sort should show messages sorted by sender from a to z and the messages from each sender should be sorted from the most recent date to the least recent date.

Its not really a bug but a feature seamonkey should have. With Microsoft outlook I can do sorts by multiple fields and it remembers the past sorts and sorts by
the hierarchy of sorts.
Confirming for now, but I'm pretty sure it's a dupe of a bug we have but I can't find at the moment. 
Status: UNCONFIRMED → NEW
Ever confirmed: true
Mmh, since 57898 is now Core, I think both 254128 and this one here could be duped to 57898. Mike, do you agree?
This problem has still not been addressed. Are there plans to fix it or should I go back to Microsoft Mail?
It's worked on in bug 57898.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 57898
You need to log in before you can comment on or make changes to this bug.