Spell check does not work after upgrade to TB 2.0 beta

RESOLVED INCOMPLETE

Status

--
major
RESOLVED INCOMPLETE
12 years ago
10 years ago

People

(Reporter: moz_jg, Assigned: mscott)

Tracking

PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

17.20 KB, application/x-javascript
Details
8.83 KB, application/x-javascript
Details
(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: version 2 beta 2 (20070116)

The spell check feature in Thunderbird 2b2 on Mac OSX doesn't not work.  

* I've downloaded and installed the English language pack from https://addons.mozilla.org/thunderbird/dictionaries/?lang=en-US.  

* In the preferences under Composition > Spelling, both spell check options are checked.

* When misspelling words (for example: "adfasdfs"), I do not get the inline spell check underline.

* When clicking Options > Check Spelling the dialog says there are no misspelled words.


I've just downloaded a new version of TB2b2, put it in another directory and run it on a fresh profile and experienced the same problem.  The nightly 3a1 build works as expected -- but this is for version 3.0, right?

Reproducible: Always

Steps to Reproduce:
1. Verify spell checking is turned on in preferences under Composition > Spelling
2. Compose email with misspelled words
3. Notice no underlines and spell check dialog does not find any misspellings.

Comment 1

12 years ago
I have an intel mac running 10.4.8 and am not seeing this.

Are you seeing any messages in the console? Any other symptoms?
(Reporter)

Comment 2

12 years ago
I don't see any errors in the Error Console for inline misspellings, however, I get this error that I get when I open the Check Spelling dialog:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIEditorSpellCheck.GetNextMisspelledWord]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: chrome://editor/content/EdSpellCheck.js :: NextWord :: line 298"  data: no]
(Reporter)

Updated

12 years ago
Version: unspecified → 2.0
(Reporter)

Comment 3

12 years ago
Any thoughts on what I might do to resolve this?  Could it be a bad install?

Comment 4

12 years ago
Can you try a clean install without the extra dictionary and see if you have the problem? I am not sure what else to suggest.
(Reporter)

Comment 5

12 years ago
OK, I removed:

 * /Applications/Thunderbird.app
 * ~/Library/Thunderbird/


Downloaded the en-US Thunderbird 2.0b2 from http://www.mozilla.org/projects/thunderbird/all-beta.html

It seems to be working now.  When I tried to port over the prefs.js it broke again, so I'll diff the files to try to find the problem.

Comment 6

12 years ago
While you are checking that. Why did you feel the need to install a en-us langauge pack? If you got the default en-us TB, then you should not have needed this. Did you start with a TB that had been localized for some other language and then needed to install English?
(Reporter)

Comment 7

12 years ago
I originally was using TB 1.5 for en-us, then upgraded to the 2.0 beta.  When the spell checking stopped working, I decided to install the language pack in hopes of fixing the problem.

I suspect it's something in the prefs.js.  When I created a new profile, and tried to reuse the old prefs.js -- the same problem occurred.  With a fresh prefs.js everything works fine.

Comment 8

12 years ago
Can you attach the old and new prefs.js files?
(Reporter)

Comment 9

12 years ago
I found the problem.  For some reason the "spellchecker.dictionary" pref was set to "en" instead of "en-US". I'm not sure how this got changed, but somehow this occurred after installing the TB 2.0 beta 2.

I also had the Lightening extension installed -- if that's any help.

Comment 10

12 years ago
I cannot cause the problem by setting the preference. Can you upload your two prefs.js files?
(Reporter)

Comment 11

12 years ago
Created attachment 260534 [details]
Old prefs.js

The old pref.js file
(Reporter)

Comment 12

12 years ago
Created attachment 260535 [details]
New prefs.js

The old prefs.js file
(Reporter)

Comment 13

12 years ago
OK, they're attached.  This is for my corporate mail, so I've had to 'xxx' out the server paths, etc; sorry.

Comment 14

11 years ago
also doesn't fail for me if pref set to "en", version 3.0a1pre (2007110302) and 2.0.0.7pre

dupe of bug 366255?
Summary: Spell check does not work at all → Spell check does not work after upgrade to TB 2.0 beta
Reporter, does this still occur in the latest supported stable 2.0.0.x?

(it is known that spell check is borky / broken on the trunk)
Whiteboard: closeme 2008-07-31
RESO INCO per lack of response to last comment. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
Whiteboard: closeme 2008-07-31
You need to log in before you can comment on or make changes to this bug.