Closed Bug 374235 Opened 14 years ago Closed 13 years ago

Breakpad should replace Talkback in future versions of Sunbird

Categories

(Calendar :: Build Config, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: omarb.public, Assigned: martinschroeder)

References

Details

Attachments

(4 files, 2 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl-PL; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: 

There is a new crash- reporting client that will be integrated with Mozilla products. It should be included in Calendar roadmap...

Reproducible: Always
As I understand the code is already built by default on Win32 (the exception handler is set in XRE_Main). Changes are needed in packages-static to package the breakpad client. Am I right? Something like this?:


; [Updater]
 bin\updater.exe
+
+; [crash reporter]
+bin\crashreporter.exe
+bin\crashreporter.ini


Patch from bug 368206 can be used to enable breakpad on the Mac.
Status: UNCONFIRMED → NEW
Component: General → Sunbird Only
Ever confirmed: true
OS: Windows XP → All
QA Contact: general → sunbird
Hardware: PC → All
Summary: Breakpad should replace talkback extension in future versions of Mozilla Calendar → Breakpad should replace Talkback in future versions of Sunbird
Component: Sunbird Only → Build Config
QA Contact: sunbird → build
I have a patch in hand to disable Talkback and enable Breakpad after the patches from bug 386925 will have been checked in.
Assignee: nobody → mschroeder
This is the part one of replacing Talkback with Breakpad.
Depends on: 391545
Status: NEW → ASSIGNED
Added disable sending of crash reports on tinderboxen per environment variable.
Attachment #274629 - Attachment is obsolete: true
This patch is TRUNK only because not all files are in sync between MOZILLA_1_8_BRANCH and TRUNK. I'll file a follow-up bug for clean-up.
Attachment #280352 - Flags: review?(preed)
Attachment #280353 - Flags: review?(ted.mielczarek)
Attachment #280352 - Flags: review?(preed) → review+
Comment on attachment 280353 [details] [diff] [review]
Enable Breakpad and remove Talkback leftovers

r=me on the build parts, I'm not really competent on the NSIS stuff, but it looks pretty sane.  FWIW, you'll still need a few more things in your tinder-config to actually enable symbol uploading, and you'll need some IT work to get a directory on stage to upload them to.  See bug 386726 for the SeaMonkey equivalent.
Attachment #280353 - Flags: review?(ted.mielczarek) → review+
Oh, nevermind, I totally missed that bug that's set blocking this.
Comment on attachment 280353 [details] [diff] [review]
Enable Breakpad and remove Talkback leftovers

Requesting additional review for NSIS installer changes.
Attachment #280353 - Flags: review?(robert.bugzilla)
Comment on attachment 280353 [details] [diff] [review]
Enable Breakpad and remove Talkback leftovers

>Index: calendar/installer/windows/nsis/installer.nsi
>===================================================================
>RCS file: /cvsroot/mozilla/calendar/installer/windows/nsis/installer.nsi,v
>retrieving revision 1.9
>diff -u -8 -p -r1.9 installer.nsi
>--- calendar/installer/windows/nsis/installer.nsi	16 Aug 2007 21:34:52 -0000	1.9
>+++ calendar/installer/windows/nsis/installer.nsi	10 Sep 2007 15:55:59 -0000
>@@ -774,38 +709,20 @@ Function preComponents
>   ${Unless} ${FileExists} "$EXEDIR\optional\extensions\inspector@mozilla.org"
>     Abort
>   ${EndUnless}
>   !insertmacro MUI_HEADER_TEXT "$(OPTIONAL_COMPONENTS_TITLE)" "$(OPTIONAL_COMPONENTS_SUBTITLE)"
>   !insertmacro MUI_INSTALLOPTIONS_DISPLAY "components.ini"
> FunctionEnd
> 
> Function leaveComponents
>-  ; If DOMi exists then it will be Field 2.
>-  ; If DOMi doesn't exist and talkback exists then TalkBack will be Field 2 but
>-  ; if DOMi doesn't exist we won't display this page anyways.
>-  StrCpy $R1 2
>-  ${If} ${FileExists} "$EXEDIR\optional\extensions\inspector@mozilla.org"
>-    ${MUI_INSTALLOPTIONS_READ} $R0 "components.ini" "Field $R1" "State"
>-    ; State will be 1 for checked and 0 for unchecked so we can use that to set
>-    ; the section flags for installation.
>-    SectionSetFlags 1 $R0
>-    IntOp $R1 $R1 + 1
>-  ${Else}
>-    SectionSetFlags 1 0 ; Disable install for DOMi
>-  ${EndIf}
>-
>-  ${If} ${FileExists} "$EXEDIR\optional\extensions\talkback@mozilla.org"
>-    ${MUI_INSTALLOPTIONS_READ} $R0 "components.ini" "Field $R1" "State"
>-    ; State will be 1 for checked and 0 for unchecked so we can use that to set
>-    ; the section flags for installation.
>-    SectionSetFlags 2 $R0
>-  ${Else}
>-    SectionSetFlags 2 0 ; Disable install for TalkBack
>-  ${EndIf}
>+  ${MUI_INSTALLOPTIONS_READ} $R0 "components.ini" "Field 2" "State"
>+  ; State will be 1 for checked and 0 for unchecked so we can use that to set
>+  ; the section flags for installation.
>+  SectionSetFlags 1 $R0
Use the following:
SectionSetFlags ${Section2} $R0

r=me for the installer portions with that changed.

I'm updating the common code in bug 392303 so it should be easier to get SunBird up to the latest changes in the other toolkit apps and to maintain going forward.
Attachment #280353 - Flags: review?(robert.bugzilla) → review+
Addressing nit. Carrying forward review.
Attachment #280353 - Attachment is obsolete: true
Attachment #280754 - Flags: review+
Setting checkin-needed (TRUNK ONLY!).
Keywords: checkin-needed
(In reply to comment #11)
Does the patches need Module owner approval before?
(In reply to comment #12)
> (In reply to comment #11)
> Does the patches need Module owner approval before?
> 

Withdrawing checkin-needed.
Keywords: checkin-needed
Daniel, can you give an answer to comment#12?
I am ok with the changes; checked in on trunk.
We need to clobber the win32 trunk tinderbox to clean the srcdir and use a separate objdir.
Attachment #280913 - Flags: review?(daniel.boelzle)
Comment on attachment 280913 [details] [diff] [review]
Clobber win32 trunk tinderbox to use objdir after distclean

Checked in on HEAD.
Attachment #280913 - Flags: review?(daniel.boelzle) → review+
Part from "Disable Talkback on Trunk tinderboxen (also enable objdir on Win32 tinderbox) v2" that has not been checked in.
Comment on attachment 280929 [details] [diff] [review]
Disable crashreporter on tinderbox

Daniel, can you check his in. It looks like you have checked in the old version with this part missing.
Checked in on HEAD.
We migrated from Talkback to Breakpad. I'll file separate bugs for problems that may appear. -> FIXED
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Version: unspecified → Trunk
Verified with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007092404 Calendar/0.6a1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.