assertion, start up messenger and click on a news server

VERIFIED DUPLICATE of bug 34196

Status

MailNews Core
Backend
P3
normal
VERIFIED DUPLICATE of bug 34196
18 years ago
10 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

I meant to log this a while ago.

the problem is we are trying to open up 
"D:\seamonkey\mozilla\dist\WIN32_D.OBJ\Users50\sspitzer\News\host-chupacabra.mc
om.com.msf\"

instead 
of 
"D:\seamonkey\mozilla\dist\WIN32_D.OBJ\Users50\sspitzer\News\host-chupacabra.mc
om.com.msf"

alec, scott, do either of you have a bug about not opening a summary file for 
the server?  I vaguely remember a bug like that.

NTDLL! 77f7629c()
nsDebug::Assertion(const char * 0x0184cbb0, const char * 0x0184cabc, const char 
* 0x0184ca8c, int 0x0000004e) line 191 + 13 bytes
mork_assertion_signal(const char * 0x0184cbb0) line 78 + 31 bytes
morkEnv::NewError(const char * 0x0334ee80) line 369 + 19 bytes
morkFile::NewFileErrnoError(morkEnv * 0x033fd5c0) line 272
morkStdioFile::new_stdio_file_fault(morkEnv * 0x033fd5c0) line 668
morkStdioFile::OpenStdio(morkEnv * 0x033fd5c0, const char * 0x033fd678, const 
char * 0x0184cdfc) line 739
morkStdioFile::morkStdioFile(morkEnv * 0x033fd5c0, const morkUsage & {...}, 
nsIMdbHeap * 0x0102a8a8, nsIMdbHeap * 0x0102a8a8, const char * 0x033fd678, 
const char * 0x0184cdfc) line 693
morkStdioFile::CreateNewStdioFile(morkEnv * 0x033fd5c0, nsIMdbHeap * 
0x0102a8a8, const char * 0x033fd678) line 393 + 61 bytes
morkFile::CreateNewFile(morkEnv * 0x033fd5c0, nsIMdbHeap * 0x0102a8a8, const 
char * 0x033fd678) line 191 + 17 bytes
orkinFactory::CreateNewFile(nsIMdbEnv * 0x03337ea8, nsIMdbHeap * 0x0102a8a8, 
const char * 0x033fd678, nsIMdbFile * * 0x0012e038) line 347 + 17 bytes
nsMsgDatabase::OpenMDB(nsMsgDatabase * const 0x033ff180, const char * 
0x033fd678, int 0x00000001) line 772 + 30 bytes
nsNewsDatabase::Open(nsNewsDatabase * const 0x02dc9100, nsIFileSpec * 
0x02d7d1d0, int 0x00000001, int 0x00000000, nsIMsgDatabase * * 0x020fa1b0) line 
120 + 29 bytes
nsMsgNewsFolder::GetDatabase(nsIMsgWindow * 0x02d4aca0) line 361 + 66 bytes
nsMsgNewsFolder::UpdateFolder(nsMsgNewsFolder * const 0x020fa13c, nsIMsgWindow 
* 0x02d4aca0) line 392
XPTC_InvokeByIndex(nsISupports * 0x020fa13c, unsigned int 0x0000002a, unsigned 
int 0x00000001, nsXPTCVariant * 0x0012e340) line 139
nsXPCWrappedNativeClass::CallWrappedMethod(JSContext * 0x02108e90, 
nsXPCWrappedNative * 0x02de1130, const XPCNativeMemberDescriptor * 0x0252030c, 
nsXPCWrappedNativeClass::CallMode CALL_METHOD, unsigned int 0x00000001, long * 
0x02498024, long * 0x0012e4f0) line 898 + 43 bytes
WrappedNative_CallMethod(JSContext * 0x02108e90, JSObject * 0x02516248, 
unsigned int 0x00000001, long * 0x02498024, long * 0x0012e4f0) line 200 + 34 
bytes
js_Invoke(JSContext * 0x02108e90, unsigned int 0x00000001, unsigned int 
0x00000000) line 686 + 23 bytes
js_Interpret(JSContext * 0x02108e90, long * 0x0012ee18) line 2483 + 15 bytes
js_Invoke(JSContext * 0x02108e90, unsigned int 0x00000001, unsigned int 
0x00000002) line 702 + 13 bytes
js_InternalInvoke(JSContext * 0x02108e90, JSObject * 0x02533e10, long 
0x025161e8, unsigned int 0x00000000, unsigned int 0x00000001, long * 
0x0012efb0, long * 0x0012ef50) line 775 + 19 bytes
JS_CallFunctionValue(JSContext * 0x02108e90, JSObject * 0x02533e10, long 
0x025161e8, unsigned int 0x00000001, long * 0x0012efb0, long * 0x0012ef50) line 
2794 + 31 bytes
nsJSContext::CallEventHandler(nsJSContext * const 0x02109c80, void * 
0x02533e10, void * 0x025161e8, unsigned int 0x00000001, void * 0x0012efb0, int 
* 0x0012efac, int 0x00000000) line 787 + 33 bytes
nsJSEventListener::HandleEvent(nsIDOMEvent * 0x02de5df4) line 154 + 64 bytes
nsEventListenerManager::HandleEventSubType(nsListenerStruct * 0x029b31f0, 
nsIDOMEvent * 0x02de5df4, unsigned int 0x00000008, unsigned int 0x00000007) 
line 703 + 19 bytes
nsEventListenerManager::HandleEvent(nsIPresContext * 0x020f4d90, nsEvent * 
0x0012f514, nsIDOMEvent * * 0x0012f4ac, unsigned int 0x00000007, nsEventStatus 
* 0x0012f534) line 1197 + 35 bytes
nsXULElement::HandleDOMEvent(nsXULElement * const 0x0277d190, nsIPresContext * 
0x020f4d90, nsEvent * 0x0012f514, nsIDOMEvent * * 0x0012f4ac, unsigned int 
0x00000001, nsEventStatus * 0x0012f534) line 3294
nsXULTreeElement::FireOnSelectHandler(nsXULTreeElement * const 0x02db7f5c) line 
556
nsXULTreeElement::SelectCell(nsXULTreeElement * const 0x02db7f58, 
nsIDOMXULElement * 0x02de1700) line 209
nsTreeFrame::SetSelection(nsIPresContext * 0x020f4d90, nsTreeCellFrame * 
0x024af0d0) line 146
nsTreeCellFrame::HandleMouseDownEvent(nsIPresContext * 0x020f4d90, nsGUIEvent * 
0x0012fa2c, nsEventStatus * 0x0012f938) line 251
nsTreeCellFrame::HandleEvent(nsTreeCellFrame * const 0x024af0d0, nsIPresContext 
* 0x020f4d90, nsGUIEvent * 0x0012fa2c, nsEventStatus * 0x0012f938) line 204
PresShell::HandleEventInternal(nsEvent * 0x0012fa2c, nsIView * 0x02a57b80, 
nsEventStatus * 0x0012f938) line 3394 + 38 bytes
PresShell::HandleEvent(PresShell * const 0x022351c4, nsIView * 0x02a57b80, 
nsGUIEvent * 0x0012fa2c, nsEventStatus * 0x0012f938, int & 0x00000001) line 
3314 + 23 bytes
nsView::HandleEvent(nsView * const 0x02a57b80, nsGUIEvent * 0x0012fa2c, 
unsigned int 0x00000008, nsEventStatus * 0x0012f938, int & 0x00000001) line 774
nsView::HandleEvent(nsView * const 0x02235800, nsGUIEvent * 0x0012fa2c, 
unsigned int 0x0000001c, nsEventStatus * 0x0012f938, int & 0x00000001) line 747
nsViewManager2::DispatchEvent(nsViewManager2 * const 0x022359e0, nsGUIEvent * 
0x0012fa2c, nsEventStatus * 0x0012f938) line 1372
HandleEvent(nsGUIEvent * 0x0012fa2c) line 69
nsWindow::DispatchEvent(nsWindow * const 0x022356d4, nsGUIEvent * 0x0012fa2c, 
nsEventStatus & nsEventStatus_eIgnore) line 511 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012fa2c) line 532
nsWindow::DispatchMouseEvent(unsigned int 0x0000012e, nsPoint * 0x00000000) 
line 3291 + 21 bytes
ChildWindow::DispatchMouseEvent(unsigned int 0x0000012e, nsPoint * 0x00000000) 
line 3498
nsWindow::ProcessMessage(unsigned int 0x00000201, unsigned int 0x00000001, long 
0x00a20073, long * 0x0012fd90) line 2436 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x001700c0, unsigned int 0x00000201, unsigned int 
0x00000001, long 0x00a20073) line 764 + 27 bytes
USER32! 77e71820()

Comment 1

18 years ago
this might be a dup of 6402.  Adding bienvenu in case he has any ideas.  

Comment 2

18 years ago
this is always because the parent path/directory for the mork file has not created.
causes an assertion, but nothing bad happens.  moving to m18.
Status: NEW → ASSIGNED
Target Milestone: --- → M18
clearing milestone, m17 and m18 are meaningless now.  these need to be triages
along with the rest.
Target Milestone: M18 → ---

Updated

17 years ago
QA Contact: lchiang → stephend
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
This is a dup of bug 34196

*** This bug has been marked as a duplicate of 34196 ***

Comment 6

17 years ago
Confirmed.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.