Downloaded dmg file using camino not recognised by system

VERIFIED INVALID

Status

Camino Graveyard
Downloading
VERIFIED INVALID
11 years ago
11 years ago

People

(Reporter: David, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.10) Gecko/20070228 Camino/1.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.10) Gecko/20070228 Camino/1.0.4

Downloaded dmg files to desktop using camino are not recognised by system on core 2 duo 17" iMac. Same files downloaded by Safari are recognised. 

This has happened a number of times. I have run disk repair permissions; reinstalled Camino 1.4; and cleared the cache and reset Camino with no success. My knowledge does not extend to any further actions to remedy this. Any help would be appreciated. Thanks.

Reproducible: Always

Steps to Reproduce:
1. Repeated downloads repeated on Intel iMac
2. Repeated downloads on PPC iBook
3.
Actual Results:  
Problem is consistently reproducible on the Intel iMac.

Please note that the same downloaded files on a PPC iBook opened without a problem.



Expected Results:  
Problem unique to Intel iMac??

This problem really should not occur. I cannot account for the change that seems to be happening to the downloaded dmg file.


Please note that the downloaded file from Camino on the Intel iMac is different in appearance to the same file downloaded with Safari on the same machine. 

Camino is set as my default browser.
Can you please provide sample URLs?  Also, are the file sizes of the .dmgs downloaded by Camino and Safari identical (or downloaded by Camino on PPC and on Intel)?
(Reporter)

Comment 2

11 years ago
Hi Smokey

Thanks for the response.

As an example, the iChax installer .dmg from http://www.ksuther.com/chax/
will open correctly with Safari on the Intel only. Using Camino, the message 'you cannot open the application "" because it is not supported on this system' is displayed.

BTW this installer is universal, as you will note at the above URL.

On the PPC it opens perfectly using either Camino or Safari. Because the installer opens correctly using Safari, the files are understandably a different size.

Cheers

Comment 3

11 years ago
(In reply to comment #0)
> Please note that the downloaded file from Camino on the Intel iMac is different
> in appearance to the same file downloaded with Safari on the same machine. 

Sounds like your iMac has been set to open disk images with the wrong app. If you right-click and choose Open With -> DiskImageMounter, does it work?
(Reporter)

Comment 4

11 years ago
Hi Stuart

I found that I can right-click and open the file with DiskImageMounter. Thanks for the tip.

Does this mean that I need to change a setting in Camino to facilitate opening a file from the download window pane, or is there a system preference that can be changed instead?

I appreciate your help.

Cheers
(Reporter)

Comment 5

11 years ago
As a postscript to my comment above, I right-clicked on the downloaded dmg file and noted that the default application for opening this file was HexEdit for some reason. I changed it to DiskImageMounter as the default.

I trust this was the right thing to do. Anyway, you have been most helpful. It confirms the value of Bugzilla community to Mozilla users around the world. Thanks.

Comment 6

11 years ago
Closing INVALID, since it's not a Camino bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID

Comment 7

11 years ago
And yes, changing the default app for disk images to DiskImageMounter was the right thing to do.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.