Specific keyboard driver uncorrectly mapped

RESOLVED DUPLICATE of bug 316449

Status

()

Firefox
Shell Integration
RESOLVED DUPLICATE of bug 316449
11 years ago
11 years ago

People

(Reporter: Olivier Hammam, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

When using the specific keyboard driver (here, the french designed driver named "kbdfrac", it can be found at http://home.pro.tiscali.be/~fbou2235/kbdfrac.htm), it doesn't work correctly for some keys.

This driver allows to type some specific characters for french users, as "Ç" (char 128, uppercase C with cedilla) or "É" (char 144, uppercase E with accent) that you can usually access with the Alt+Numpad typing. With this driver you can access these chars with a AltGr+Key sequence (for char 128 AltGr+C, for char 144 AltGr+W). For the most, the driver works well but for some, specially for these two chars, there's a mapping problem, or something like that: when you type AltGr+W, in place of the uppercase E with accent you get the lowercase character ("é", char 130).

This occurs only with Firefox (no problem with other Windows apps, only with some DOS programs) and it occurs with any text input areas in an HTML page.

Reproducible: Always

Steps to Reproduce:
Only one step: installing the keyboard driver and it happens.


Expected Results:  
Recognition of non-standard (extended) windows keyboard drivers

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 316449
You need to log in before you can comment on or make changes to this bug.