If laptop suspend/resumes, firefox no longer connects. Must restart ff

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: Koby Leung, Unassigned)

Tracking

({hang})

1.5.0.x Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9) Gecko/20070131 Fedora/1.5.0.9-2.fc6 Firefox/1.5.0.9 pango-text
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9) Gecko/20070131 Fedora/1.5.0.9-2.fc6 Firefox/1.5.0.9 pango-text

When I suspend/resume the laptop, the state of the connection seems to be lost. I am able to connect using other applications, but firefox hangs and no connection is made. Sometimes changing the connection settings works - where I tell it to auto detect, and reset it to 'direct connection' to the internet, but that is a pain to do every time.

This bug is annoying - particularly if multiple tabs are displayed.

Reproducible: Always

Steps to Reproduce:
1. Open firefox and surf
2. Suspend laptop, resume laptop, ensure that connection is restored.
3. Connect with firefox again.
Actual Results:  
Firefox cannot connect, and displays the standard 'no connection' error.

Expected Results:  
Firefox detects the network change/ flushes its connection cache and connects

Using Dell Inspiron 700m, Fedora Core 6

Comment 1

11 years ago
" I haven't seen this happen in awhile. I've upgraded multiple components though, so someone somewhere must have fixed it. ... please close."  WFM per reporter
Severity: normal → critical
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Keywords: hang
Resolution: --- → WORKSFORME
Version: unspecified → 1.5.0.x Branch
You need to log in before you can comment on or make changes to this bug.