Closed Bug 374458 Opened 13 years ago Closed 11 years ago

Make reftest and crashtest write its own preferences/profile

Categories

(Testing :: Reftest, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: rcampbell, Assigned: ted)

References

Details

Invoke reftest from a script like runtests.pl in mochitest to create and run a specific profile. Currently the testing boxes are running reftest directly and creating a dummy profile (or just using defaults that have been changed). This is undesirable if reftest ever changes preferences requirements on one or more platforms.

See, bug 371866 for earlier discussion.
Component: Layout → Testing
QA Contact: layout → testing
Have you considered reusing any of the code I use for this type of thing?
Out of interest, what is the code you use, and does it have anything in common with mochitest's runtests.pl?
Duplicate of this bug: 386620
So for what it's worth in bug 379959 I'm now needing to set some preferences in order to correctly run tests. I can work around it for now by manually changing a bunch of tests, but it's definitely a pain (and in this case risks breaking crashtests in ways we won't detect)
Summary: Make reftest write its own preferences/profile → Make reftest and crashtest write its own preferences/profile
Component: Testing → Reftest
Product: Core → Testing
Version: Trunk → unspecified
QA Contact: testing → reftest
Blocks: 469518
Version: unspecified → Trunk
Bug 430652 has a patch containing code to do this (and some other stuff, that needs to be taken out of it).
We could probably just use automation.py nowadays and write a runtests.py-like script that handles anything special that's needed.
The code in bug 430652 does that (it just has a little too much extra for the "anything special that's needed").
FYI, there are probably enough different scripts that have been checked in that do similar, but not quite identical, things to enable automated testing that there could be a "Tools" section of the page http://developer.mozilla.org/en/Mozilla_automated_testing.

I could start such a section but I would have to do a "find src -name \*py -o -name \*pl" and I am sure there is a smarter way to find these....
Assignee: nobody → ted.mielczarek
Blocks: 421611
Status: NEW → ASSIGNED
Looks like the patch in bug 468913 fixes this too.
Fixed in bug 468913.
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
No longer blocks: 469518
You need to log in before you can comment on or make changes to this bug.