Thunderbird does not seem to respect font preferences when replying

RESOLVED DUPLICATE of bug 250539

Status

Thunderbird
Message Compose Window
--
major
RESOLVED DUPLICATE of bug 250539
11 years ago
7 years ago

People

(Reporter: Gregory Gerard, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: 2.0b2

I have my font set to fixed with. I replied to an email, started typing and noticed it was Times. Looked at the combo-box and sure enough, it was set to Variable Width.

In general (and I know this is overly broad but I finally had the mind isolate this one), font handling in Thunderbird is wonky. The font seems to track the last font the caret was at forcing awkward keystrokes to keep it from laying down the wrong style. I don't know if the two are related and I will work on an isolated test case for it, but it might be salient.

Reproducible: Always

Steps to Reproduce:
1. Reply to message with composition font set to Fixed Width
Actual Results:  
Got Variable Width font

Expected Results:  
Fixed width font

I had similar font weirdness with 1.5 and upgraded to 2.0b2 to see if it would vanish, but the font handling wonkiness didn't change.

Comment 1

10 years ago
Exactly same problem on linux.
Font selection in compose mode does not work at all.

TB 2.0.0.4 and 2.0.0.5pre.

Comment 2

10 years ago
Similar problem with Window XP.  I've noticed various font style problems over various versions - Thunderbird 1.0.6, 1.5.0.10 and currently version 2.0.0.6 (20070728).

Instead of respecting bold face, italics or color changes in fonts and font styles, Thunderbird places asterisks at the location where font styles were to change.

Comment 3

10 years ago
(In reply to comment #2)
> Instead of respecting bold face, italics or color changes in fonts and font
> styles, Thunderbird places asterisks at the location where font styles were to
> change.

This is due to a problem with auto-detect not considering those style changes "sufficient" enough to switch to an HTML send. You have to explicitly enforce it using Options > Format > Rich Text in the composition window then.

An enhancement request is pending (bug 136502) to be able to switch off the auto-detect functionality, thus to always respect the preference of sending out HTML messages or to present the ask-what-to-do dialog.

Updated

9 years ago
Assignee: mscott → nobody

Comment 4

9 years ago
Same issue with Shredder on Windows.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090201 Lightning/1.0pre

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 250539
You need to log in before you can comment on or make changes to this bug.