don't focus cancel in "Cancel sending mail" confirmation

RESOLVED DUPLICATE of bug 384568

Status

--
enhancement
RESOLVED DUPLICATE of bug 384568
12 years ago
8 years ago

People

(Reporter: golub_m, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2) Gecko/20060601 Firefox/2.0.0.2 (Ubuntu-edgy)
Build Identifier: 1.5.0.10 (20070306)

When you send messages status window with progress bar appears. The keyboard focus is on the cancel button by default and Esc cancels too. It is too easy to cancel even if you do not want it and Thunderbird asks no questions. Confirmation dialogue would be suitable. It is annoying if the message takes dozens of minutes to send.

Reproducible: Always

Steps to Reproduce:
1. Pick a big file and send it as attachment. Wait for status window to appear. Press Esc, Spacebar or Enter.
Actual Results:  
"Failed to send message"

Expected Results:  
When the status window appears Cancel must not have keyboard focus.
Confirmation window instead of Cancelling instantly. (At least if the message took several minutes to send)

I mark it as bug, please change to Enh. if needed.

Updated

10 years ago
Assignee: mscott → nobody
Severity: normal → enhancement
Component: General → Mail Window Front End
OS: Linux → All
QA Contact: general → front-end
Hardware: PC → All
Summary: Missing "Cancel sending mail" confirmation. → don't focus cancel in "Cancel sending mail" confirmation
Whiteboard: dupeme

Comment 1

8 years ago
gotcha!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Component: Mail Window Front End → Message Compose Window
QA Contact: front-end → message-compose
Resolution: --- → DUPLICATE
Whiteboard: dupeme
Duplicate of bug: 384568
You need to log in before you can comment on or make changes to this bug.