Modal dialog is not truly modal

RESOLVED DUPLICATE of bug 197351

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 197351
11 years ago
11 years ago

People

(Reporter: Carl Fritch, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 2.0.50727)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

When you open a window in firefox with the modal=yes you do not get a truly modal window.  The code in the javascript continues to execute after the window opens.

Consider the following:
window.open('dt.enewsroom.econtact.EditOneEmployeeType.cls','New Type','status,scrollbars,modal=true,resizable,width=300,height=225');
	alert('window is not modal');

On MS Explorer the alert will not execute until after the "modal" window is closed.


This is tied to an issue I sent to Intersystems listed below.  Thier zenpopupwindow() opens a window "modal" by default.  Please contact them if you have any questions about their system.


Thanks,
Carl
From: support@intersystems.com [mailto:support@intersystems.com] 
Sent: Tuesday, March 20, 2007 7:35 AM
To: john.paladino@intersystems.com; Dimitri Fane; bmccor@intersystems.com; Carl Fritch; Sudheer.Gaddam@intersystems.com; seton@intersystems.com
Subject: Cache 656977 High Digital Technology International, LLC. Open

Problem No: 656977
Status: Open	Priority: High	Open Date: 19 Mar 2007	Open Time: 12:34PM
Advisor: Albert Goins	Product: Caché Unknown	Hardware: 	Next Action Date: 21 Mar 2007	Type: Investigate
End User: Digital Technology International, LLC.	Application Provider: Digital Technology International, LLC.	Contact: Carl Fritch	Classification: Zen

Customer Description: popup window is not modal in Zen

    
When I create zen popup window using Firefox it is not "modal".
we tried adding "modal" and 
"modal=true" to the popup windows parameters but they did not work:

Method newButtonClicked() [ Language = 
javascript 
]
{
	//zenPage.getComponentById('contactTypeId')
//	zenLaunchPopupWindow(url,'mediaPreview','status,scrollbars,resizable,width=400,height=400');
	var x = 
zenLaunchPopupWindow('dt.enewsroom.econtact.EditOneEmployeeType.cls','Edit 
Type','status,scrollbars,resizable,width=300,height=225');
	//alert('after zenlaunch');
	
	var employeeTypeName = 
zenPage.SessionRead('employeeTypeName','a');
	return;
	var newsCheckValue = zenPage.SessionRead('newscheckValue','false');
	var mediaCheckValue = 
zenPage.SessionRead('mediaCheckValue','false');
	
	if (employeeTypeName.length > 0) // something to 
do
	{
		var newsChk = 0;
		var mediaChk = 0;
		if (newsCheckValue.indexOf('true') > -1)
			newsChk 
= 1;
	    if (mediaCheckValue.indexOf('true') > -1)
	       mediaChk = 1;
	    
	    var status = 
zenPage.insertIntoTable(employeeTypeName,newsChk,mediaChk); 
	    
zenPage.getComponentById('contactTypeId').executeQuery(1);  		
	}
}

    


Reproducible: Always

Steps to Reproduce:
1.create code that has a modal window 
2. place an alert('') after that code
3.load the window... note the alert will execute after the modal window is loaded
Actual Results:  
see notes:

Expected Results:  
A modal window should come to the forground.  The code that calls the window should stop execution until the modal window is closed.

Comment 1

11 years ago
Dup of bug 197351 or bug 360312.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 197351

Comment 2

11 years ago
mid air 

You need special privileges to use modal windows. They do block further execution but does not keep the window on top. 

See bug 197351 and bug 180048.

Use:

function f() {
   try {
      netscape.security.PrivilegeManager.enablePrivilege('UniversalBrowserWrite');
      window.open('http://localhost/', 'name', 'modal');
      alert('foo');
   } 
   catch(ex)
   { 
     alert(ex); 
   }
}

f();

I can't get alwaysRaised to work though.
You need to log in before you can comment on or make changes to this bug.