Add "allow anyone to take ownership of this extension" option

VERIFIED DUPLICATE of bug 278234

Status

addons.mozilla.org Graveyard
Developer Pages
VERIFIED DUPLICATE of bug 278234
11 years ago
2 years ago

People

(Reporter: Jason Spiro, Unassigned)

Tracking

4.x (triaged)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: 

It would be great if extension writers could set permissions on their extensions so that anyone could claim ownership.

Then, if the original author disappears, it becomes much easier for someone to update the install.rdf, retest, and upload an update.

Reproducible: Always
(Reporter)

Comment 1

11 years ago
Plus, I also want an option to let anyone translate my extension's description etc. into other languages.
(Reporter)

Updated

11 years ago
Summary: Add "allow anyone to take ownership of this extension" option, so that less extensions will become orphaned → Add "allow anyone to take ownership of this extension" and "allow anyone to localize description" options
The "allow anyone to localize" is going to be a part of a larger decision on how to handle translations of add-ons.  It hasn't been decided yet, but I started a discussion a couple weeks ago here:

http://groups.google.com/group/mozilla.dev.l10n.web/browse_thread/thread/362661d3588bb24b/1c494bb0a02170d2

I think the original bug and comment #1 are two different bugs.
Status: UNCONFIRMED → NEW
Component: Administration → Developer Pages
Ever confirmed: true
Summary: Add "allow anyone to take ownership of this extension" and "allow anyone to localize description" options → Add "allow anyone to take ownership of this extension" option
Target Milestone: --- → 3.x (triaged)
Version: unspecified → 3.0

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 278234
Verified dup
Status: RESOLVED → VERIFIED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.