Patrocles Needs the Platform SDK Installed on it

RESOLVED WONTFIX

Status

Thunderbird
Build Config
RESOLVED WONTFIX
11 years ago
8 years ago

People

(Reporter: Scott MacGregor, Unassigned)

Tracking

x86
Windows XP
Bug Flags:
blocking-thunderbird2 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
I just noticed that the 1.5.0.x machines for Thunderbird and Firefox are both listed as WINNT 5.2. Builds from these machines are built with the following command line flag:

-DOSTYPE=\"WINNT5.2\"

The same is true for Thunderbird and Firefox on the trunk.

However Patrocles, the build machine for Thunderbird 1.8, is listed as WINNT5.0 so we use the following flag:

-DOSTYPE=\"WINNT5.0\"

I'm nervous about shipping thunderbird 2 builds that are built from a different version of windows that 1.5.0.x and the trunk. I suspect this might be the cause of issues like Bug #306599 but am still investigating that. I wonder if there are other issues lurking there that we don't know about.
Flags: blocking-thunderbird2+
(Reporter)

Comment 1

11 years ago
Note: I don't know that this is a blocker, I don't know what it means to pass in different values of DOSTYPE between different release branches. Maybe the bits come out the same regardless of the value. But I'd like confirmation that it's ok for that value to differ just to be safe.

Updated

11 years ago
Summary: Thundebird 1.8 Windows Branch Machine has DOSTYPE = WINNT5.0 → Thunderbird 1.8 Windows Branch Machine has DOSTYPE = WINNT5.0
(Reporter)

Comment 2

11 years ago
It also looks like Patrocles does not have the windows platform SDK installed
on it per the build guidelines for Mozilla 1.8:

http://developer.mozilla.org/en/docs/Windows_Build_Prerequisites_on_the_1.7_and_1.8_Branches#Platform_SDK

Thanks to Gavin and Ted for pointing this out.

In addition to installing the right SDK (can we verify the SDK that Pacific is
using for Firefox branch nightlies?)
we need to make sure the SDK paths get appended before the VC6 paths:

rem --- Prepend SDK paths
rem --- Only required for MSVC6
set PATH=%MSSDK%\bin;%PATH%
set INCLUDE=%MSSDK%\include;%INCLUDE%
set LIB=%MSDDK%\lib;%LIB%
(Reporter)

Comment 3

11 years ago
adjusting the summary accordingly and minusing this. We aren't going to do this before the release but may do something afterwards.
Flags: blocking-thunderbird2+ → blocking-thunderbird2-
Summary: Thunderbird 1.8 Windows Branch Machine has DOSTYPE = WINNT5.0 → Patrocoles Needs the Platform SDK Installed on it
QA Contact: build → build-config
Summary: Patrocoles Needs the Platform SDK Installed on it → Patrocles Needs the Platform SDK Installed on it
Given where we are on branch, i.e. TB 2.0.0.14, do we really want to change this now or let it go?

If we want to change it, then probably need to move to the mozilla.org product and something like server operations for tinderbox or release engineering.
Assignee: mscott → nobody

Comment 6

10 years ago
It's hard to tell without trying it.  It would be interesting to know what versions the trunk is using, though.
(In reply to comment #7)
> v6.0, afaik
> (from here:
> http://wiki.mozilla.org/ReferencePlatforms/Win32#Install_Microsoft.C2.AE_Windows.C2.AE_Software_Development_Kit_Update_for_Windows_Vista)
> 

Well the tinderbox header on trunk shows WIN NT 5.1, but the SDKVER in the log shows 6.

I can't actually confirm what Patrocles has at the moment - it doesn't have such useful environment variables.
2.x is no longer supported, we don't need this bug any more.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.