Suiterunner - Crash when open MailNews

RESOLVED INVALID

Status

SeaMonkey
MailNews: Message Display
--
critical
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: Tobias Fischer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a3pre) Gecko/20070319 Mnenhy/0.7.4.10010 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a3pre) Gecko/20070319 Mnenhy/0.7.4.10010 SeaMonkey/1.5a

Windows Suiterunner Builds will crash when open MailNews. This regressed between 2007-03-08-13 and 2007-03-11-22, the next Build I have got here. 

Build from tpol ID: 2007030813 works like expected, MailNews startup fine and works.
Next available Build here is 2007031112, this and the following Builds until last tested 2007032023 will crash imediatly when I try to open MailNews.

Reproducible: Always

Steps to Reproduce:
1. Get an actual tpol Suiterunner-Build
2. Start SeaMonkey-Suiterunner, open MailNews
3. SeaMonkey crashes. 



Sorry, that I can't cut down the regression-window:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-03-08+13%3A00%3A00&maxdate=2007-03-11+22%3A00%3A00&cvsroot=%2Fcvsroot
Have you tried running suiterunner in safe mode? (-safe-mode I think)

What about a fresh profile?
Oh, and have you checked a normal SeaMonkey trunk build?
(Reporter)

Comment 3

11 years ago
Humm, thanks for the hint. Suiterunner-Build 2007032023 will launch MailNews in
safe mode (-safe-mode was right) without an crash. 

Normal (XPFE) Trunk-Builds won't crash open MailNews, I use them everyday until Suiterunner-Builds reach such state, that I can change to them. For me, Bug 361903 has to be fixed, get an working Downloadmanager and Tabbed-Browsing must be a little better. :)

I will try it with an new profile today in evening, but first I have to
do my payed work. 
(In reply to comment #3)
> Humm, thanks for the hint. Suiterunner-Build 2007032023 will launch MailNews in
> safe mode (-safe-mode was right) without an crash. 

Ok, that most likely means one of your extensions is causing the problem (possibly Mnenhy?), when you get time try disabling them individually until you find the problem one.
(Reporter)

Comment 5

11 years ago
Now I have tried to disable some of the installed Add-Ons. First I have disabled Mnenhy and Enigmail, after restart MailNews open without crash. But when I enable one of the Add-Ons again, SeaMonkey will crash, curiously also when I disable both again. I have to disable some other Add-Ons to avoid the Crash from open MailNews. 

I have to try it later with an new and clean Profile, probably my profile is more damaged than I thought. 
(In reply to comment #5)
> Now I have tried to disable some of the installed Add-Ons. First I have
> disabled Mnenhy and Enigmail, after restart MailNews open without crash. But
> when I enable one of the Add-Ons again, SeaMonkey will crash, curiously also
> when I disable both again. I have to disable some other Add-Ons to avoid the
> Crash from open MailNews. 

It may be that some of the interfaces/libraries that the extensions are relying on have changed and as a result the extensions are causing the crash. As the crash doesn't happen without the extensions installed, then this isn't a suiterunner problem in the first instance - you should take it to the extension owners, if it turns out to be a bug in our code (e.g. a bit we don't always exercise) then they are welcome to raise a bug on the actual problem. Therefore resolving this as invalid as its not a specific suiterunner problem.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.