Bug 374774 (nbsp_space)

When entering nonbreaking spaces into a form, they get converted to normal spaces.

RESOLVED DUPLICATE of bug 206925

Status

()

RESOLVED DUPLICATE of bug 206925
12 years ago
12 years ago

People

(Reporter: Firebird.10.BobBlaylock, Unassigned)

Tracking

1.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

  Many year ago, I reported this exact same bug regarding the Windows version of what was then called “Firebird”.  When entering text into a form, if you enter a nonbreaking space (option-space from a Macintosh, Alt-160 from a Windows system) it gets posted as a normal space.

Reproducible: Always

Steps to Reproduce:
1.  Go to any web forum where you can enter text into messages, for example.
2.  Enter a message, using nonbreaking spaces.  I conventionally start a paragraph with two to indent, and follow a period or end-of-sentence with a nonbreaking space and then a normal space.
3.  Post the message, and take note that the nonbreaking spaces are gone.  Viewing source will usually show that they've been replaced with normal spaces, which, of course, get condensed in the standard way that HTML renders multiple spaces.
Actual Results:  
  I have started this paragraph by typing two nonbreaking spaces.  There is also a nonbreaking space immediately after the period ending the last sentence, followed by a normal space, and then this sentence.  I expect that as entered, these nonbreaking spaces will have turned to normal spaces.

Expected Results:  
  Nonbreaking spaces should be posted as nonbreaking spaces, and not as normal spaces.  If I had meant to enter normal spaces, then I would have typed normal spaces.
(Reporter)

Updated

12 years ago
Alias: nbsp_space
Version: unspecified → 1.0 Branch
(In reply to comment #0)
>   Many year ago, I reported this exact same bug

Indeed you did. In order to spare the people cc:ed to the bug that actually fixed this for Firefox 3.0 any more notification email, I'll mark this as a duplicate of your last one, rather than the one it was a duplicate of, or the one that was a duplicate of.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 206925
You need to log in before you can comment on or make changes to this bug.