In test plan view, clicking on test case ID gives popup - 'unresponsive script'

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
12 years ago
4 years ago

People

(Reporter: sandrea, Assigned: gregaryh)

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

When user clicks on test case ID number in the list of test cases for a test plan, a dialog box pops. The popup takes some time to appear and meanwhile the browser is unresponsive.

Dialog message:

Warning: Unresponsive script
A script may be busy, or may have stopped responding, You can stop the script now or you can continue to see if the script will complete.

The user is given the options 'Stop Script' and 'Continue'



Reproducible: Always

Steps to Reproduce:
1. go to http://bugz.deanza.edu/bugzilla_testopia/tr_show_plan.cgi?plan_id=10
2. click on test case id 313
3. wait
Actual Results:  
The test case page starts to load. Then, after a wait, a popup box appears. If stop script is pressed, page finishes loading almost immediately. If continue is selected, there is a brief wait prior to the page loading.

Expected Results:  
page should load immediately in its entirety.
(Reporter)

Comment 1

12 years ago
The same thing happens when starting with a test run (such as the one at this URL) and following the same steps. 

http://bugz.deanza.edu/bugzilla_testopia/tr_show_run.cgi?run_id=47&case_id=313

Comment 2

12 years ago
I can't reproduce this problem after following the steps in comment 0 or comment 1. This might be because I have a fairly fast machine (3.20GHz Pentium 4). Both pages finished loading in just a few seconds.

This might help if you're using Firefox:

1. Type about:config in the address bar and hit enter.
2. In the filter box enter dom.max_script_run_time.
3. Change the value from 5 to something higher, I used 60.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Comment 3

12 years ago
See also http://trac.dojotoolkit.org/ticket/2384

The more Testopia tabs are open in Firefox, the slower Firefox (and your computer) will be.
You need to log in before you can comment on or make changes to this bug.