Closed Bug 374820 Opened 15 years ago Closed 13 years ago

vertical scrollbars showing in the major update / EULA part of the software update UI

Categories

(Toolkit :: Application Update, defect, P2)

x86
macOS
defect

Tracking

()

RESOLVED FIXED
mozilla1.9.1b3

People

(Reporter: moco, Assigned: robert.strong.bugs)

References

(Depends on 1 open bug)

Details

(4 keywords)

Attachments

(4 files)

vertical scrollbars showing in the major update / EULA part of the software update UI

screen shots coming.

to reproduce, set your app.update.url.override pref to http://www.sspitzer.org/empty.xml

I'm on Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a3pre) Gecko/20070208 Minefield/3.0a3pre

This is a regression, but I don't think the software update xul / css has changed at all recently.
note, it is the outer most (right) scroll bar that is new, and was not there before.  the inner most scroll bar is supposed to be there because the content is too tall for the xulbrowser.
Product: Firefox → Toolkit
Appears to also affect weave. Bug 442868
Keywords: polish
Attached patch patch rev1Splinter Review
This appears to fix it on a QA system for me. I believe the buttons along the bottom are the culprit.
Assignee: nobody → robert.bugzilla
Attachment #359633 - Flags: review?(dtownsend)
filed bug 476048 for the underlying issue with Wizards on Mac OS X.
Depends on: 476048
Dave, could you also verify this fixes this since I don't have a Mac? I did my testing on one of the QA machines and believe this is a decent workaround for this issue. Thanks
Attachment #359633 - Flags: review?(dtownsend) → review+
Comment on attachment 359633 [details] [diff] [review]
patch rev1

Yes this fixes the issue
Pushed to mozilla-central
http://hg.mozilla.org/mozilla-central/rev/759e7042e2d1
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Attachment #359633 - Flags: approval1.9.1?
Comment on attachment 359633 [details] [diff] [review]
patch rev1

Drivers, this is an extremely simple polish fix for the vertical scrollbar appearing in the update ui on Mac OS X.
Priority: -- → P3
Requesting wanted1.9.0.x since this is an extremely safe fix and it would be nice if Mac users didn't have to see that unnecessary scrollbar when we release 3.1
Flags: wanted1.9.0.x?
Flags: blocking1.9.1+
Priority: P3 → P2
Comment on attachment 359633 [details] [diff] [review]
patch rev1

a191=beltzner
Attachment #359633 - Flags: approval1.9.1? → approval1.9.1+
Pushed to mozilla-1.9.1
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/4e235c238483
Keywords: fixed1.9.1
Target Milestone: --- → mozilla1.9.1b3
Attachment #359633 - Flags: approval1.9.0.8?
Attachment #359633 - Flags: approval1.9.0.7?
Comment on attachment 359633 [details] [diff] [review]
patch rev1

1.9.0.x drivers, this is a simple / safe fix that would be to get in for 1.9.0.x so Mac users won't have to see the unnecessary scrollbar when we release 3.1.
Rob, the box looks still a bit displaced. See the attachment. Shall I file a new bug on that?
Attachment #359633 - Flags: approval1.9.0.7?
(In reply to comment #15)
> Created an attachment (id=361829) [details]
> displaced background of update box
> 
> Rob, the box looks still a bit displaced. See the attachment. Shall I file a
> new bug on that?
That is controlled by the remote html / css and hence is not an app update bug... you should file a websites -> www.mozilla.com bug to have that fixed
(In reply to comment #16)
> That is controlled by the remote html / css and hence is not an app update
> bug... you should file a websites -> www.mozilla.com bug to have that fixed

Unless its a test I think I'll wait with filing a new bug on that. I'll do it when we will have a real billboard available.

Meanwhile I can verify the fix with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090211 Shiretoko/3.1b3pre Ubiquity/0.1.5 ID:20090211020510

Rob, I don't think that there is a way to verify it on trunk right now?
Comment on attachment 359633 [details] [diff] [review]
patch rev1

Approved for 1.9.0.8, a=dveditz for release-drivers
Attachment #359633 - Flags: approval1.9.0.8? → approval1.9.0.8+
Bah... I landed it but the tree still states requirement for approval1.9.0.7 on patches so I backed it out until it is open for 1.9.0.8.
The tree rules were a lie! Please re-land and sorry about that.
Landed for 1.9.0.8 / Firefox 3.0.8

Checking in mozilla/toolkit/themes/pinstripe/mozapps/update/updates.css;
/cvsroot/mozilla/toolkit/themes/pinstripe/mozapps/update/updates.css,v  <--  upd
ates.css
new revision: 1.10; previous revision: 1.9
done
Keywords: fixed1.9.0.8
Flags: wanted1.9.0.x?
Verified for 1.9.0.8 with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.8pre) Gecko/2009031904 GranParadiso/3.0.8pre.
You need to log in before you can comment on or make changes to this bug.