Having a version in the Sandbox removes all previous public versions from view

RESOLVED INVALID

Status

addons.mozilla.org Graveyard
Public Pages
--
major
RESOLVED INVALID
11 years ago
2 years ago

People

(Reporter: eviljeff, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: 

I've used my own extension as an example.  According to my developer control panel, there are numerous older public versions, the most recent being 0.7.2, the version available from the existing addons.mozilla.org site.  Yet despite this the extension only shows up under a sandbox search/browse, and none of the older public versions seem to be downloadable.


Reproducible: Always

Steps to Reproduce:
1.  Search for 'Attachment Extractor' Thunderbird extension or go to above link in non-sandbox mode
2.  Rub eyes in dismay because nothing found
3.
Actual Results:  
Gives Extension not-found error page

Expected Results:  
The most recent public version, 0.7.2, should be offered up for download.

If this isn't just a problem with my extension then it removes from view any extension which has a newer version waiting to be reviewed, a major problem I would have thought.
Although you have previous files/versions that are public, they do not override your add-on's status, which is current "Sandbox; Public Nomination" as indicated in your Developer Control Panel.

If your nomination is approved and your add-on becomes public, then it should work as you describe.

For more details on the process, see http://preview.addons.mozilla.org/en-US/firefox/pages/sandbox
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → INVALID
Version: unspecified → 3.0
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.