If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Center aligned table overlaps left aligned table

VERIFIED FIXED

Status

()

Core
Layout: Tables
P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: JLSDev, Assigned: karnaze (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
The following code allows the table on the right [align="center"] to overlap the
table on the left [align="left"] in m15 and NS 6 when horizontal window size
reduced - Works fine in NS 4.71, IE 4.5 and IE 5.0 - on Mac PPC; G3; 450MHz;
256MB RAM; OS 8.6 - Just downloaded the m15 release tonight.

<html>
<body background="images/edge3.gif" bgcolor="#FFFFFF">

<div style="position: absolute; top: 02px; left: 0px;">
	<img src="images/LOGOwk.jpg" alt="Spectrum" width="150" height="75" border="0"
align="middle">
</div>
<table border="1" cellspacing="0" cellpadding="5" width="150" height="600"
align="left">	
	<tr>
		<td valign="top" height="100"></td>
	</tr>	
	<TR>
		<td><font color="#FFcC11" face="Verdana" style="font-size: 12px;"><b>Young
Adults</b></font></td>
	</TR>	
	<TR>
		<td><A HREF="design.htm">Graphic Design</A></td>
	</TR>	
	<tr>
		<td><a href="index.htm">Home</A></td>
	</tr>		
	<tr>
		<td valign="top" height="200"></td>
	</tr>	
</table>
<table border="1" align="center">	
	<tr>
		<td>		
		<table border="1" width="520" align="center">			
			<TR>
				<td width="130"><img src="images/Capturing.gif" alt="Capturing People"
width="130"
				height="182"></td> <td align="right" width="130"><img
src="images/youths/image10.jpg" alt="10"
				width="128" height="180"></TD> <td align="left"><IMG
SRC="images/youths/image11.jpg" WIDTH="125"
				HEIGHT="179"></TD> <td width="130"></td>
			</TR>			
			<TR>
				<td align="center" width="130"><IMG SRC="images/youths/image5.jpg"
WIDTH="125" HEIGHT="179"></TD>
				<td align="center" valign="middle" colspan="2" width="260"><IMG
SRC="images/youths/image4.jpg"
				WIDTH="179" HEIGHT="125"></td> <td align="center" width="130"><IMG
SRC="images/youths/image3.jpg"
				WIDTH="125" HEIGHT="179"></TD>
			</TR>			
			<TR>
				<td width="130"></td> <td align="right" width="130"><IMG
SRC="images/youths/megan.jpg"
				WIDTH="125" HEIGHT="179"> </td><td align="left" width="130"><IMG
SRC="images/youths/image15.jpg"
				WIDTH="125" HEIGHT="179"></TD><td width="130"><img src="images/MoveYou.gif"
				alt="Images That Move You" width="130" height="182"></td>
			</TR>			
		</table>
		<table border="1" width="150" height="150" align="center">			
			<tr>
				<td></td>
			</tr>			
		</table>		
		<table border="1" width="510" align="center">			
			<tr>
				<td align="center"> <IMG SRC="images/bar.gif"
ALT="-------------------------------------------"
				BORDER="0" WIDTH="450" HEIGHT="08"><br>
				<IMG SRC="images/bar.gif" ALT="-------------------------------------------"
BORDER="0" WIDTH="450"
				HEIGHT="08"></td>
			</tr>			
		</table>		
		</td>
	</tr>	
</table>

</BODY>

</HTML>

Comment 1

18 years ago
The problem is visible on M16 2000-042609 as well.
A variant/duplicate of 30366?

Comment 2

18 years ago
agreed.

confirming with m15 (build id: 2000041805) on win98.
moving plat/os to ALL.

attachment to follow.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac System 8.5 → All
Hardware: Macintosh → All

Comment 3

18 years ago
Created attachment 8068 [details]
the inline test case, but viewable.
(Assignee)

Comment 4

18 years ago
I'm getting the following assertion (but only when Viewer loads this document 
first). 
    <div style="position: absolute; top: 02px; left: 0px;">
      <img src="raptor.jpg" alt="Spectrum" width="150" height="75" border="0"
        align="middle">
    </div>
    <table border="1" align="center"> 
      <tr> 
        <td>table2 
          <table border="1" width="510" align="center"> 
            <tr> <td align="center"> 
                <IMG SRC="raptor.jpg" 
ALT="-------------------------------------------" BORDER="0" WIDTH="450" 
HEIGHT="08">
              </td> 
            </tr> 
          </table> 
        </td> 
      </tr> 
    </table>

nsDebug::Assertion(const char * 0x021706f8, const char * 0x021706e4, const char 
* 0x021706a4, int 337) line 191 + 13 bytes
nsAbsoluteContainingBlock::IncrementalReflow(nsIFrame * 0x00dd0b10, 
nsIPresContext * 0x0229be70, const nsHTMLReflowState & {...}, int 2250, int 
1125, int & 0, nsRect & {...}) line 337 + 32 bytes
nsAreaFrame::Reflow(nsAreaFrame * const 0x00dd0b10, nsIPresContext * 0x0229be70, 
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0) 
line 236
nsAbsoluteContainingBlock::ReflowAbsoluteFrame(nsIFrame * 0x00dd09b4, 
nsIPresContext * 0x0229be70, const nsHTMLReflowState & {...}, int -1, int -1, 
nsIFrame * 0x00dd0b10, nsReflowReason eReflowReason_Incremental, unsigned int & 
0) line 422 + 37 bytes
nsAbsoluteContainingBlock::Reflow(nsIFrame * 0x00dd09b4, nsIPresContext * 
0x0229be70, const nsHTMLReflowState & {...}, int -1, int -1, nsRect & {...}) 
line 215
nsAreaFrame::Reflow(nsAreaFrame * const 0x00dd09b4, nsIPresContext * 0x0229be70, 
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0) 
line 288 + 44 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x00dd09b4, nsIPresContext * 
0x0229be70, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0, 
int 0, unsigned int 0, unsigned int & 0) line 643 + 31 bytes
CanvasFrame::Reflow(CanvasFrame * const 0x00dd06b4, nsIPresContext * 0x0229be70, 
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0) 
line 300
nsBoxToBlockAdaptor::Reflow(nsBoxLayoutState & {...}, nsIPresContext * 
0x0229be70, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0, int 0, int 0, int 9180, int 4470, int 1) line 660
Status: NEW → ASSIGNED
(Assignee)

Comment 5

18 years ago
Fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 6

17 years ago
Using 9/14 build, verifying fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.