Status

()

--
critical
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: goku90504, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Mozilla Firefox seems to just take up more and more memory the longer you use it at first it use's realitively little memory but the longer you run it the more memory it takes up even closing tab's doesn't lessen the amount of memory it takes up it eventually reaches the point that clicking any link or switching between any tab takes several min for the computer to do

Reproducible: Always

Steps to Reproduce:
1. run the program continuously for several days or weeks or even months
2.
3.


Expected Results:  
Use less memory 

default theme only google plug in (as far as i know)
This report is basically useless since it's far too general. There are known memory issues in firefox, some of which are leaks, others which are poor memory management.

Make sure your Flash player is up to date (9.0r28 for windows) and make sure your other plugins are up-to-date too. Try in firefox's safemode to see if that changes anything ( http://kb.mozillazine.org/Safe_mode ) and give http://plugindoc.mozdev.org/faqs/memusage.html a read.

Firefox 3 will have a spiffy new cycle collector in which will hopefully help matters. But unless you can come up with definite examples of firefox leaking memory (as opposed to having bad memory management) then there's not much point in a bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Comment 2

12 years ago
It always happens.
I keep opened my FF nearly 2 days . I close only hibernate option with my XP.
but it never releases memory.
also i close FF but still in memory i can ses firefox.exe with huge memory.
You need to log in before you can comment on or make changes to this bug.