Scroll bars of select box with size > 2 show when visibility set to hidden

RESOLVED DUPLICATE of bug 187435

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 187435
11 years ago
11 years ago

People

(Reporter: Allan Jardine, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a2pre) Gecko/20070206 Minefield/3.0a2pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a2pre) Gecko/20070206 Minefield/3.0a2pre

As the test page shows when a select box is rendered by Firefox the scroll bars are shown, despise the 'visibility:hidden' style. Furthermore the scroll bars appear on top of any element which is floated above them using css styles. Effectively it appears that the scroll bars are on top of all other elements on the page. It doesn't matter whether the number of elements in the list is greater or less than the select size.

This can be reproduced on Firefox 1.0.8, Firefox 2.0.0.x, and right through to MineField 3.0a2pre (haven't checked pre 1.0.8). This bug only occurs on a Mac (10.4.7 was the testing machine), and not on Windows (unable to test Linux).

Reproducible: Always

Steps to Reproduce:
1. Use size > 1 for select menu
2.Apply style visibility: hidden
3.
Actual Results:  
Scroll bars are shown, although the content is not.

Expected Results:  
Nothing should show.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 187435
You need to log in before you can comment on or make changes to this bug.