Closed Bug 374936 Opened 13 years ago Closed 13 years ago

Moving event from one calendar to another fails in calTransactionManager.js

Categories

(Calendar :: Internal Components, defect)

x86
Windows 2000
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ssitter, Assigned: ssitter)

References

Details

(Keywords: regression)

Attachments

(1 file)

Thunderbird 2.0pre (20070321) + Lightning 0.5pre (2007032003)

Moving event from one calendar to another fails in calTransactionManager.js

Steps To Reproduce:
1. Create two calendars
2. Create event in calendar 1
3. Edit event and move to calendar 2
4. Press Ok

Actual Results:
Nothing happens. Error in console:
  Error: this.mOldCalendar has no properties
  Source File: file:///C:/[...]/js/calTransactionManager.js
  Line: 178

Regression Range:
Works in Lightning 0.5pre (2007-03-20-03)
Fails in Lightning 0.5pre (2007-03-22-04)
This was caused by a copy and paste error in Bug 369262:

+++ calendar/base/content/calendar-item-editing.js
-            case 'move':
-                this.mOldCalendar = this.mOldItem.calendar;

+++ calendar/base/src/calTransactionManager.js
+            case 'move':
+                this.mOldCalendar = this.mOldItem.mCalendar;

Also adding mOldCalendar back to prototype.
Assignee: nobody → ssitter
Status: NEW → ASSIGNED
Attachment #259334 - Flags: first-review?(michael.buettner)
Comment on attachment 259334 [details] [diff] [review]
rev0 - bustage fix

looks good to me, r=mickey.
Attachment #259334 - Flags: first-review?(michael.buettner) → first-review+
Checked in on trunk and MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Verified with thunderbird version 2.0pre (20070324), lightning 2007032404 and lightning-wcap 20070324
VERIFIED per comment#4
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.