If I try to open some websites, Firefox spontaneously closes

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: glyn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-07-14, URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1) Gecko/20061010 Firefox/2.0

./firefox -safe-mode --sync
The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 118 error_code 8 request_code 144 minor_code 3)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)


Reproducible: Always

Steps to Reproduce:
1.open firefox
2.go to website www.myspace.com
3.firefox shuts down
Actual Results:  
browser disserpears

Expected Results:  
displaed a web page
(Reporter)

Updated

12 years ago
Summary: If i try to open some websites firefox spntainiously closes → If i try to open some websites firefox spontainiously closes
Summary: If i try to open some websites firefox spontainiously closes → If I try to open some websites, Firefox spontaneously closes

Comment 1

12 years ago
This bug might be a dupe of Bug 304370.

Comment 2

12 years ago
Glyn, either way Firefox 2.0 is way too old to be using. You need to update _now_.
(Reporter)

Comment 3

12 years ago
I have updated to the latest version and i am still seeing the same problem

Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
do you still see this problem using FF 3.5 beta**, or FF 3.0 started in safe mode***?

If yes, please comment
If not, please close with resolution set to WORKSFORME or INVALID (if problem was extension or the like)

** http://www.mozilla.com/en-US/firefox/all-beta.html
*** http://support.mozilla.com/en-US/kb/Safe+Mode
Whiteboard: closeme 2009-07-14

Comment 5

10 years ago
I'm not sure if it is strictly x86 arch but on 64 bit it works fine and doesn't crash (using FF 3.5 openSUSE 11.1 x86_64 Java 1.6.13 and Alpha Flash Plugin).
Resolving as WORKSFORME.  If this issue can be reproduce on Firefox 3.5, we
will reopen the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.