Closed Bug 374969 Opened 13 years ago Closed 13 years ago

Deleting profile created on Desktop folder is removing all files from Desktop and Desktop folder itself

Categories

(Toolkit :: Startup and Profile System, defect)

PowerPC
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 270705

People

(Reporter: ibalak, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Firefox 2.0.0.3

Hardware Overview:

  Machine Name:	Mac Pro
  Machine Model:	MacPro1,1
  Processor Name:	Dual-Core Intel Xeon
  Processor Speed:	2.66 GHz
  Number Of Processors:	2
  Total Number Of Cores:	4
  L2 Cache (per processor):	4 MB
  Memory:	2 GB
  Bus Speed:	1.33 GHz
  Boot ROM Version:	MP11.005C.B04
  SMC Version:	1.7f8
  Serial Number:	G87081G9UPZ

System Software Overview:

  System Version:	Mac OS X 10.4.9 (8P2137)
  Kernel Version:	Darwin 8.9.1
  Boot Volume:	Macintosh HD
  Computer Name:	ibalak-mac
  User Name:	ibalak (ibalak)



Reproducible: Always

Steps to Reproduce:
1. Create Profile on Desktop folder.
2. Start Firefox.
3. Restart Firefox and remove Profile created on Desktop
Actual Results:  
Deleting profile created on Desktop folder is removing all files from Desktop and Desktop folder itself. It removed all files and Desktop folder itself. On logout/login no file has been recovered or stored in Trash folder.

Expected Results:  
1. No files should be removed from Desktop folder.
2. No Desktop folder should be removed.

Warn user that Profile should not be created on Desktop folder itself or not allowed to remove other file and Desktop folder.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 270705
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.