Problems with AllPeers download page

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED FIXED
11 years ago
2 years ago

People

(Reporter: Matthew Gertner, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
- The short description "Share your files privately..." is displayed twice at the top of the screen, once in italic and once normal.
- Above the download button I see the text "AllPeers Beta is not available for Windows" twice (looks like a dupe of bug 373842).
- The size listed is not that of the Windows version. This makes me wonder if the version available for download is actually the Windows version.
- The number of downloads is not visible on the page (by design?)

Comment 1

11 years ago
I grabbed all 3 platforms of the latest release from allpeers directly and from production remora.  Only one hash from remora matches what's on the allpeers site and it matches for the wrong platform.  For reference the pre-remora hashes at time of insertion to the amo db and links to the files directly from allpeers are at Bug 369350.

jeremy$ gsha1sum */* | sort  
0d31936cd3314de7b15517208d2c88d91f2758ef  addons.mozilla.org/allpeers_beta-0.55.1-fx-windows.xpi
22342121192837f33b1d97da614c518aaa0ab34d  allpeers.com/allpeers_beta-0.55-fx-macosx.xpi
4a7879ff85e00efe14f1eef779a7ace5a23145af  addons.mozilla.org/allpeers_beta-0.55.1-fx-macosx.xpi
4a831613425bf159533326e7b35513d1bfbeb0f0  allpeers.com/allpeers_beta-0.55-fx-windows.xpi
89c413f46c6c6be1102ab867995a1adf8f16aaa3  addons.mozilla.org/allpeers_beta-0.55.1-fx-linux.xpi
e7a8b637735223446c83a2bcff0fd513532c85b8  allpeers.com/allpeers_beta-0.55-fx-linux.xpi
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → 3.0

Comment 2

11 years ago
(In reply to comment #1)
Please ignore my last comment.
(Reporter)

Comment 3

11 years ago
Also the number of downloads listed in the Control Panel hasn't changed since this morning. I don't know whether this is a problem with the downloading or the counter.
Short description displayed once is a general problem with descriptions imported from old AMO version, guess the authors are supposed to edit it. Download counts not being public is bug 371836.
I filed bug 375278 for the "download numbers not updating" issue.

Comment 6

11 years ago
(In reply to comment #4)
> Short description displayed once is a general problem with descriptions
> imported from old AMO version, guess the authors are supposed to edit it.
> 
This is correct. We have a new field in Remora for a very short add-on summary which is for display on search pages and at the very top of add-on's pages. It's intended to give the user a very quick indication of what the add-on does. Make it informative and keyword heavy as it's a strong player in sorting search results by relevance.

Comment 7

11 years ago
Argh, apologies... I forgot the main point of my comment. During migration we had to fill this field with something, so we use the beginning of the add-on description. It is expected that active add-on developers will write a new summary fairly soon after the site is released, or ideally during the testing phase.
(Reporter)

Comment 8

11 years ago
Looking a lot better. Note that the file size displayed for the Windows version is still incorrect (it looks like the size of the Linux version).
(Reporter)

Comment 9

11 years ago
Justin said I should clarify the file size problem. Basically we need the JS to adjust the file size according to the operating system of the visitor, since the sizes are different for Windows, Linux and Macintosh. This is especially a shame since the already quite large Windows version, which is our primary platform, displays the size of the Linux version and thus appears much larger.
Can you file specific, well-summarized bugs for the outstanding issues you'd like addressed?  It's hard to keep track of what in here has been fixed, and what won't be, etc.
(Reporter)

Comment 11

11 years ago
On Mike's request I filed a new (hopefully specific and well-summarized) bug for the file size issue: https://bugzilla.mozilla.org/show_bug.cgi?id=376591

As far as I know this is the only outstanding issue so I guess this bug can be resolved to FIXED.
Marking fixed (see prev. comment).
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.