Version/config bumps for Tb 2.0.0.0

RESOLVED FIXED in Thunderbird2.0

Status

Thunderbird
Build Config
--
blocker
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: nthomas, Assigned: nthomas)

Tracking

Thunderbird2.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(10 attachments, 7 obsolete attachments)

5.76 KB, patch
preed
: review+
Details | Diff | Splinter Review
1.22 KB, patch
preed
: review+
Details | Diff | Splinter Review
1.74 KB, patch
preed
: review+
rhelmer
: superreview+
Details | Diff | Splinter Review
1.81 KB, patch
preed
: review+
Details | Diff | Splinter Review
13.74 KB, patch
nthomas
: review+
Details | Diff | Splinter Review
1.45 KB, patch
kohei
: review+
Details | Diff | Splinter Review
4.30 KB, patch
rhelmer
: review+
Details | Diff | Splinter Review
3.19 KB, patch
rhelmer
: review-
Details | Diff | Splinter Review
5.51 KB, patch
rhelmer
: review+
Details | Diff | Splinter Review
3.03 KB, patch
Scott MacGregor
: review+
Details | Diff | Splinter Review
(Assignee)

Description

11 years ago
Tracking bug for version and config bumps for the Thunderbird 2.0 release.
Flags: blocking-thunderbird2?
(Assignee)

Comment 1

11 years ago
Created attachment 259441 [details] [diff] [review]
tb2 tinder-config & mozconfig bumps for en-US
Attachment #259441 - Flags: review?(preed)
Created attachment 259448 [details] [diff] [review]
 tb2 tinder-config & mozconfig bumps for l10n
Attachment #259448 - Flags: review?

Comment 3

11 years ago
Should we fix version.txt and module.ver as part of this patch too?

If the branch is called, THUNDERBIRD_2_0_RELEASE, what happens (let's hope it doesn't!) if we have to do a 2nd RC due to an issue we find with the RC? Does the branch name change?
So "THUNDERBIRD_2_0rc1_RELEASE" would be better.
(Assignee)

Comment 5

11 years ago
Created attachment 259461 [details] [diff] [review]
tb2 tinder-config & mozconfig bumps for en-US

We're going to use 2.0.0.0/2_0_0_0 everywhere.
Attachment #259441 - Attachment is obsolete: true
Attachment #259461 - Flags: review?(preed)
Attachment #259441 - Flags: review?(preed)
(Assignee)

Updated

11 years ago
Summary: Version/config bumps for Tb 2.0 → Version/config bumps for Tb 2.0.0.0
Created attachment 259463 [details] [diff] [review]
L10n  tb2 tinder-config & mozconfig bumps
Attachment #259448 - Attachment is obsolete: true
Attachment #259463 - Flags: review?
Attachment #259448 - Flags: review?

Updated

11 years ago
Attachment #259463 - Flags: review? → review?(preed)
Created attachment 259464 [details] [diff] [review]
version.txt & module.ver bumps

(In reply to comment #3)
> Should we fix version.txt and module.ver as part of this patch too?

Here's the patch.
Attachment #259464 - Flags: review?(preed)
(Assignee)

Comment 8

11 years ago
Created attachment 259475 [details] [diff] [review]
bootstrap.cfg for tb 2.0.0.0

Notes:
 * I put platform specific info in for buildDir and l10n_buildDir, which requires bug 372757. I also used this for verifyConfig since this seem to be platform specific.
 * The pullDate is the mail & mailnews last checkin time. We're going to tag manually in order to take gecko 1.8.1.3 + the configure change + mail/mailnews at that time. l10n_pullDate is legit.
 * the buildPlatform vars are set for the en-US tinderboxen. Note that the l10n ones are different for win32 and linux (WINNT_5.2, Linux_2.4.20-28.8). Filed bug 375006 to support this.
Attachment #259475 - Flags: review?(preed)

Comment 9

11 years ago
Comment on attachment 259475 [details] [diff] [review]
bootstrap.cfg for tb 2.0.0.0

>productTag           = THUNDERBIRD_2_0

I think this will end up being THUNDERBIRD_2_0_0_0

>branchTag            = MOZILLA_1_8_BRANCH
>pullDate             = 2007-03-21 02:42 PST
>l10n_pullDate        = 2007-03-23 07:39 PST
>milestone            = 1.8.1.13

Should this be 1.8.1.3?

Actually, we should check with rhelmer, because we don't want to bump the milestone at all on this, and the code may bump the milestone if it's specified.

>linux_buildPlatform  = Linux_2.4.18-14
>macosx_buildPlatform = Darwin_8.7.0
>win32_buildPlatform  = WINNT_5.0

We'll have to check these to make sure they're right on the machine; looks right, though.

>blat                 = /cygdrive/d/moztools/bin/blat.exe

Also have to make sure this exists on patrocles.

This is really close, though, and it's always iterative the first time we do this for a major release.

Thanks Nick!
Attachment #259475 - Flags: review?(preed) → review-
Comment on attachment 259464 [details] [diff] [review]
version.txt & module.ver bumps

This looks good, but we'll wait to land it until the _MINIBRANCH has been created.

We now land the release version number bumps on the _MINIBRANCH only, so nightly builds always have the "pre" in them.
Attachment #259464 - Flags: review?(preed) → review+
Comment on attachment 259463 [details] [diff] [review]
L10n  tb2 tinder-config & mozconfig bumps

Kohei:

Let's go through this after the en-US builds are available; I think the package names may actually have "2.0.0.0" in them, not just "2.0"

But, the is the first time we've done things this way, so we should just see what happens when the builds run.
Attachment #259463 - Flags: review?(preed) → review-
(Assignee)

Comment 12

11 years ago
Created attachment 259639 [details] [diff] [review]
bootstrap.cfg for tb 2.0.0.0 - Mk II

Fixes productTag and milestone. I'd been assuming the later was more for documentation, since I think we need to do a manual tag of the cvsroot of the repository (to pick up the configure change and the different date for mail & mailnews).
Attachment #259639 - Flags: review?(preed)
(Assignee)

Updated

11 years ago
Attachment #259475 - Attachment is obsolete: true
(Assignee)

Comment 13

11 years ago
Created attachment 259642 [details] [diff] [review]
bootstrap.cfg for tb 2.0.0.0 - Mk III

sorry, pullDate's were reversed
Attachment #259639 - Attachment is obsolete: true
Attachment #259642 - Flags: review?(preed)
Attachment #259639 - Flags: review?(preed)

Updated

11 years ago
Flags: blocking-thunderbird2? → blocking-thunderbird2+
Comment on attachment 259642 [details] [diff] [review]
bootstrap.cfg for tb 2.0.0.0 - Mk III

Looks good to me.
Attachment #259642 - Flags: superreview?(rhelmer)
Attachment #259642 - Flags: review?(preed)
Attachment #259642 - Flags: review+
Comment on attachment 259642 [details] [diff] [review]
bootstrap.cfg for tb 2.0.0.0 - Mk III

Looks good, blat and sendmail are going to need to change on some machines; check before running.
Attachment #259642 - Flags: superreview?(rhelmer) → superreview+
(Assignee)

Comment 16

11 years ago
(In reply to comment #15)
> (From update of attachment 259642 [details] [diff] [review])
> Looks good, blat and sendmail are going to need to change on some machines;
> check before running.

Checked in as mozilla/tools/release/configs/tb-moz18-bootstrap.cfg with the blat path fixed for patrocles.

Flags: blocking-thunderbird2+ → blocking-thunderbird2?
(Assignee)

Updated

11 years ago
Attachment #259463 - Attachment description: 259448: tb2 tinder-config & mozconfig bumps for l10n → L10n tb2 tinder-config & mozconfig bumps
Comment on attachment 259461 [details] [diff] [review]
tb2 tinder-config & mozconfig bumps for en-US

Looks good here.
Attachment #259461 - Flags: review?(preed) → review+
Created attachment 259837 [details] [diff] [review]
tb2 tinder-config & mozconfig bumps for l10n
Attachment #259463 - Attachment is obsolete: true
Attachment #259837 - Flags: review?(preed)

Updated

11 years ago
Attachment #259837 - Flags: review?(preed) → review+
(Assignee)

Comment 19

11 years ago
Created attachment 259839 [details] [diff] [review]
bootstrap.cfg fixes

I think it makes sense to check these fixes into CVS.
Attachment #259839 - Flags: review?(preed)
Comment on attachment 259839 [details] [diff] [review]
bootstrap.cfg fixes

Yes it does, but check the l10n dirs; I think they're Clobber, not Depend.
Attachment #259839 - Flags: review?(preed) → review+
(Assignee)

Comment 21

11 years ago
(In reply to comment #20)
> (From update of attachment 259839 [details] [diff] [review])
> Yes it does, but check the l10n dirs; I think they're Clobber, not Depend.

Checked in after verifying the l10n dirs on the tbox. Clobber is used for nightlies and Depend for releases.
Created attachment 259852 [details] [diff] [review]
tb2 tinder-config & mozconfig bumps for l10n (v4)

Clobber -> Depend
Attachment #259837 - Attachment is obsolete: true
Attachment #259852 - Flags: review?(preed)
Comment on attachment 259852 [details] [diff] [review]
tb2 tinder-config & mozconfig bumps for l10n (v4)

Looks good to me; we'll see if this breaks or not. :-)
Attachment #259852 - Flags: review?(preed) → review+
Created attachment 259860 [details] [diff] [review]
tb2 tinder-config & mozconfig bumps for l10n (v5)

/builds/tinderbox/Tb-Mozilla1.8-l10n
-> /builds/tinderbox/Tb-Mozilla1.8-l10n-Release
Attachment #259852 - Attachment is obsolete: true
Attachment #259860 - Flags: review?(nrthomas)
(Assignee)

Comment 25

11 years ago
Comment on attachment 259860 [details] [diff] [review]
tb2 tinder-config & mozconfig bumps for l10n (v5)

We used this for linux and mac builds. Win32 needs another fix, see the next patch.
Attachment #259860 - Flags: review?(nrthomas) → review+
(Assignee)

Comment 26

11 years ago
Created attachment 259959 [details] [diff] [review]
win32 builds are in the rc1/unsigned dir
Attachment #259959 - Flags: review?(kohei.yoshino.bugs)

Updated

11 years ago
Attachment #259959 - Flags: review?(kohei.yoshino.bugs) → review+
(Assignee)

Comment 27

11 years ago
Created attachment 260196 [details] [diff] [review]
moz18-branch-patcher2.cfg changes
Attachment #260196 - Flags: review?(rhelmer)
Comment on attachment 260196 [details] [diff] [review]
moz18-branch-patcher2.cfg changes

>Index: moz18-branch-patcher2.cfg
>===================================================================
>RCS file: /mofo/release/patcher/moz18-branch-patcher2.cfg,v
>retrieving revision 1.21
>diff -u -u -r1.21 moz18-branch-patcher2.cfg
>--- moz18-branch-patcher2.cfg	13 Mar 2007 21:36:45 -0000	1.21
>+++ moz18-branch-patcher2.cfg	30 Mar 2007 23:52:53 -0000
>@@ -254,3 +254,116 @@
>     </exceptions>
>   </release>
> </app>
>+
>+
>+<app Thunderbird>
>+  past-update = 2.0b1 2.0b2 betatest beta
>+
>+  <current-update>
>+    from = 2.0b2
>+    to   = 2.0.0.0rc1
>+    channel = beta 
>+    testchannel = betatest 


You probably want:

channel = release beta
testchannel = releastest betatest

I would then copy the aus config and remove the "release" dirs from the copy, so you have the final version ready to go and don't need to regen later.
Comment on attachment 260196 [details] [diff] [review]
moz18-branch-patcher2.cfg changes

Nick pointed out that we don't actually need "release" channel yet since this is the first release :)

However releasetest is still useful for testing bouncer. r=me with that change, if you want to add release so we don't have to remember to add it next time, that is fine too.
Attachment #260196 - Flags: review?(rhelmer) → review+
(Assignee)

Comment 30

11 years ago
(In reply to comment #29)
> However releasetest is still useful for testing bouncer. r=me with that change,
> if you want to add release so we don't have to remember to add it next time,
> that is fine too.

Checked in with both release & releasetest added.

(Assignee)

Comment 31

11 years ago
Created attachment 260668 [details] [diff] [review]
New update verification config files
Attachment #260668 - Flags: review?(rhelmer)
Attachment #260668 - Flags: review?(rhelmer) → review+
Comment on attachment 260668 [details] [diff] [review]
New update verification config files

Oh, sorry, you don't need the 2.0.0.0 lines in here. You can leave them commented out if you like, but there's nothing for them to update to.

You want the "from" and "to" entries on the 2.0b2 line, as well.
Attachment #260668 - Flags: review+ → review-
(Assignee)

Comment 33

11 years ago
Created attachment 260734 [details] [diff] [review]
Fix update verification configs, patch against current CVS
Attachment #260734 - Flags: review?(rhelmer)
Attachment #260734 - Flags: review?(rhelmer) → review+
(Assignee)

Comment 34

11 years ago
Scott, what would you like to bump the nightly version to ? Perhaps, a simple step to 2.0.0.1pre, or sync up with Firefox and use 2.0.0.4pre.

Comment 35

11 years ago
Nick, I think we should sync up to the latest firefox release (even if we aren't going to ship a tbird 2.0.0.4. I believe that's what we do with 1.5.0.x)
(Assignee)

Comment 36

11 years ago
Created attachment 262162 [details] [diff] [review]
Post release version bump to 2.0.0.4pre
Assignee: mscott → nrthomas
Status: NEW → ASSIGNED
Attachment #262162 - Flags: review?(mscott)

Updated

11 years ago
Attachment #262162 - Flags: review?(mscott) → review+
Duplicate of this bug: 378083
(Assignee)

Comment 38

11 years ago
Version bump landed and verified. I think we're done unless there is a call for Free Software builds.
(Assignee)

Updated

11 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Assignee)

Comment 39

11 years ago
Removing blocking-thunderbird2? flag, since we shipped and I'd like to clear out my request queue.
Flags: blocking-thunderbird2?
You need to log in before you can comment on or make changes to this bug.