Style properties set in a stylesheet are not accessable via .style property

VERIFIED DUPLICATE of bug 34529

Status

()

Core
DOM
P3
normal
VERIFIED DUPLICATE of bug 34529
18 years ago
17 years ago

People

(Reporter: John Hunter, Assigned: jst)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m15)
BuildID:    2000041805

Style properties set in a global or page level stylesheet are not readable via 
the DOM using Javascript, although they can be set using script. If the 
properties are set as an inline STYLE attribute then the style properties are 
readable.

Reproducible: Always
Steps to Reproduce:
1. Open the attached test case.
2. select the report link - the returned .style.left value is null
3. select the move link - the element .style.left value is set and the  element 
moves on the page.
4. select the report link - the returned .style.left value reported correctly as 
40px.

Actual Results:  Step 2. returns an empty string.

Expected Results:  Step 2. should return the correct .style.left value of 250px.
(Reporter)

Comment 1

18 years ago
Created attachment 8078 [details]
Test case
(Assignee)

Comment 2

18 years ago
This is a dup of 34529, and it's also an invalid bug, see 34529 for description.

*** This bug has been marked as a duplicate of 34529 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.