Mouse wheel zoom broken on this page

RESOLVED INVALID

Status

()

Core
Event Handling
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: Ria Klaassen (not reading all bugmail), Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Steps to reproduce:

1. Go to http://www.nu.nl/
2. On this page press and hold Ctrl and scroll with the wheel

Result: scrolls down
Expected result: should enlarge text
Regression: on 20-2-2007

I could reproduce this also on http://forums.mozillazine.org/viewforum.php?f=23 but not on http://www.google.com/

Could not find a dependency in bug 369793 so I assume this is a new bug.

Comment 1

11 years ago
WFM (using linux).
Does windows handle scroll event in some specific way?
(Reporter)

Comment 2

11 years ago
Hm, I can explain now why nobody yet discovered this bug: the problem is only present when I use Smoothwheel to scroll which is a globally installed extension here. So I don't know anymore if this is a valid bug or only an annoyance for users of this irreplaceable extension. 

Comment 3

11 years ago
Ok, I can confirm that with SmoothWheel the bug is there.
I *guess* the problem is that earlier mousewheel event wasn't visible
to scripts when ctrl key was pressed.
Now mousewheel event is handled like any other event, so content
can access also ctrl+mousewheel event.

Comment 4

11 years ago
So in other words, I'd say this is something to be fixed in the 
extension.
(Reporter)

Comment 5

11 years ago
I hope someone will. The extension is also afflicted by bug 300030 and I hope it can be restored. Closing bug per comment 4.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.