Closed Bug 375267 Opened 14 years ago Closed 14 years ago

lightning extension silently fails when invalid ICS remote calendar URL is given

Categories

(Calendar :: Provider: ICS/WebDAV, defect)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 314594

People

(Reporter: duncan.mcnutt, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: 0.3.1 and 0.5pre (nightly build)

Lightning adds new calendar with an URL containing bogus server or path name.  Even though no such calendar path exists, no error message is given and a blank calendar is displayed!
Tested with 0.3.1 (official) and 0.5pre (nightly build from today 25. Mar. 2007).

Because manual URL entry is very prone to misspellings, I have set this to Major.


Reproducible: Always

Steps to Reproduce:
1. Add "New..." calendar
2. Select "On the Network"
3. Leave Format on "iCalendar (ICS)"
4. Enter valid URL to a web site you have WebDav access to, but enter WRONG PATH name OR enter a completely bogus site: e.g.: https://www.ical.com/ica.ics
Actual Results:  
Component finishes and shows blank calendar (urk...)

Expected Results:  
When the path name on the server is incorrect, no calendar can be created.  The component should return error: invalid/mispelled URL and recover gracefully, e.g.: show the URL entry dialog again and give the user to change the URL.  It should not fail silently and it should not show an empty calendar (suggesting that everything is fine, which it isn't obviously).

Note: if you do not have a webdav enabled site, but use a bogus url with a real site address (e.g.: https://mail.google.com/temp.ics) then it will give you a read only error.  That is not what I am trying to pin down here though.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 314594
You need to log in before you can comment on or make changes to this bug.