Keychain access hangs up/repeats request

VERIFIED DUPLICATE of bug 372153

Status

Camino Graveyard
OS Integration
--
major
VERIFIED DUPLICATE of bug 372153
11 years ago
11 years ago

People

(Reporter: Tim, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.0.10) Gecko/20070228 Camino/1.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.2pre) Gecko/20070223 Camino/1.1b

I am a medical student and access this site through a VPN set-up allowing me to use our university's site licence. When I first accessed the site, I got a dialog box asking me if I want to update the keychain for the new version of Camino. This works fine. Immediately after that, I get a dialog telling me that keychain wants to access the information for the site. When I hit "always allow" the dialog box disappears then immediately reappears. Now amount of clicking on "always allow" "allow once" or "deny" will make the dialog box disappear.

Reproducible: Always

Steps to Reproduce:
1.Sign on to vpn
2.Access website
3.The rest happens automatically


Expected Results:  
Allowed access to the keychain, then stopped asking me for access.

Comment 1

11 years ago
Could you check Keychain Access and see how many keychain entries you have for this site, and how many of them list Camino as having access to them?

Comment 2

11 years ago
From email (please post your replies here in the future, rather than emailing them):
"I appear to have 51 keychain entries for this site, 27 of which are for the new version of camino. All of those were created on the same day, the first day that I tried the new version. There are two other keychain entries for the 1.0.4 version but these were created a long time ago."

So that explains the behavior (which will be resolved by the fix for bug 372153), but I'm very confused as to how you got so many entries in the first place. Are they all identical? Are the other ~25 created by another browser, and if so are they identical as well? This may just be something wrong with your Keychain, but I'd like to make sure it's not a Camino bug.

Comment 3

11 years ago
From the last email (again, please *do not* reply to bugmail emails; each one includes a link back to the corresponding bug, where you should post your comments): "Unfortunately I deleted the Camino keychain items, but they all looked identical to me. I can download the beta again and see what happens if you want.

The other keychain items were all created by shiira it looks like. I was using that browser for a while, but it didn't work very well with the mdconsult site either. They all appear to have slightly different IP addresses, so I'm not sure if that makes them different or not. How can I tell if they are identical items?"

--

The most likely explanations are that either your keychain is damaged, or this site has login forms on a whole lot of slightly different domains (which if they are using IP address rather than domain is certainly possible). Either way, clearly the creation of multiple entries doesn't sound like a Camino bug, so I'm just going to dupe this to bug 372153 which will resolve the UE problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 372153

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.