Enhancement: Bookmark Keyword feature moved to Search feature

RESOLVED WONTFIX

Status

()

Firefox
Search
--
enhancement
RESOLVED WONTFIX
11 years ago
9 years ago

People

(Reporter: Simon, Unassigned)

Tracking

2.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

In previous versions of Firefox, the Bookmark Keyword feature was more useful than the Search Box because it was configured by default to quickly search the web using only keyboard commands. ie: typing in "g firefox" in the location bar would search Google for 'firefox'.
This was no longer included with Firefox by default in favour of including these search capabilities in the Search box feature. This however is not as good as the keyword as it requires a mouse click (or Press F4, then up/down)to select an alternative search engine which is more time consuming and not as 'quick' as going to the actual search engine website to do it.

The feature enhancement request is to move the 'Bookmark Keyword' feature to apply to the Quick Search, and for the Quick Searches bundled by default to include the keyword, and for engines added later to also include a keyword if the addon was configured for one.

Reproducible: Always

Steps to Reproduce:
1.Select the Location Bar
2. type in "g firefox"
3. Press Enter
Actual Results:  
Firefox searches the the website "g", and when that fails over it searches Google for "g firefox"

Expected Results:  
Firefox searches Google for the term "firefox"
(Reporter)

Updated

11 years ago
OS: Windows XP → All
Version: unspecified → 2.0 Branch
Obviously the default set of keywords is no longer present in Firefox 2.0.x. 
The feature still works but you need to add a keyword to your bookmarks first. In your case:
- Go to http://www.google.com/
- Right click on the input field and choose "Add a Keyword for this Search..."
- Fill in the name and a keyword (any keyword will do)
- Save them in a folder
I'm not sure we really want to bring back those default keywords given that they aren't too hard to add.
Gavin or Ryan, should we wontfix this bug?
It sounds like that it is not wanted since it is not complicated to add keywords on his own. If I should be wrong feel free to reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.