nsIWebBrowserStream display incoherent characters

RESOLVED DUPLICATE of bug 348710

Status

Core Graveyard
Java to XPCOM Bridge
RESOLVED DUPLICATE of bug 348710
11 years ago
3 years ago

People

(Reporter: sylvain ferriol, Assigned: jhp (no longer active))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9) Gecko/20061219 Iceape/1.0.7 (Debian-1.0.7-3)
Build Identifier: 1.8.0.10

when using nsIWebBrowserStream, it does not read input chars due to a bug in nsJavaWrapper.cpp.
appendToStream interface has the array parameter before the array length. nsJavaWrapper::callXPCOMMethod parse java method parameters from left to right.
but for array param it does not check the length before.
this bug only appears for all interfaces having array length after the array reference

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

11 years ago
Created attachment 259689 [details] [diff] [review]
patch which corrects this bug

Comment 2

11 years ago
Duplicate of bug 348710?
(Reporter)

Comment 3

11 years ago
(In reply to comment #2)
> Duplicate of bug 348710?
> 

yes

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 348710
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.